Designer not opening from Ignition Home Page

Mine was on a vanilla 2003 install. Still had that new PC smell-- and rich Corinthian leather.

Server 2003 huh…ok thats a good lead. We’ve been trying on XP SP2 installs, where it seems to work fine.

Hit or miss on my Xp Sp3 installs as well.
IE6 is still the stupid corporate standard though… Grr.

Well… I am running IE6 and using Windows XP on the box I am having the problems.
The funny thing is… Ignition was loaded and all was fine until JAVA update 20. I still think it could be a pointer somewhere looking for the wrong file. I know I am not as versed in all the technical stuff as most, but here is something I noticed. When I get the JAVA error…(trying to from inside the Ignition Gateway Homepage) . it seams to be looking for “Designer[1].jnlp”… but when Lanch it from the desktop link… The Java console show it launching “Designer.jnlp” . So where is the “[1]” coming from??

Anyway… I will install IE8 next week on the box I am having problems with and see if all is well.

Also… note. I have Ignition running on this laptop… using Windows XP, Service Pack 3, running IE6 , Java 6.0 update 18, and everything is fine today.

Thanks guys for your support. Carl , Colby , Travis and all other users of this forum have been VERY helpful. Great Customer Support.


The funny naming on the .jnlp is IE6 putting the jnlp file in its cache. Here is what is supposed to happen:

  1. You click on a launch link, which leads to a *.jnlp file.
  2. Browser downloads *.jnlp file, puts it in its file cache
  3. Browser looks up the file association for “jnlp”, finds javaws.exe (The Java Web-Start executable)
  4. Browser calls javaws.exe, using the path to the *.jnlp file in its cache as an argument
  5. Java web-start launches, reading the jnlp file that browser pointed it towards.

What seems to be happening is that IE6 is not actually writing the *.jnlp file to its cache, or it is being deleted from the cache before javaws.exe can read it.

Just to let everyone know… I installed IE8 and the problem was corrected.



Finally got to the bottom of this one. Turns out the answer was even in the Java web-start FAQ. This will be fixed in the next release.

That’s great news, Carl. I still have a good number of machines running Win2k and IE6. While I’d rather that IT upgraded the boxes, I have a feeling that it won’t happen as long as they limp along… :unamused:

I am having the same problem running clients on machines other than my development laptop. The development machine is WinXP SP3 with IE8. Java version 6.17

I have problems on :

Win2k SP4 with IE6
Mac OSX 10.4 with FireFox v3.0.19
MacOSX 10.4 with Safari v3.0.4

Any ideas?


We have found a problem in Ignition and Java web-start. The current release, 7.1.0, fixes this issue so please try upgrading.

OK, The issue seems to be resolved on the Win2k machine by installing v7.1.

I still, however, cannot use the Mac to load the .JNLP. I can get to the gateway screen, but when attempting to launch the application, I get the “cannot load file…” error. I do get a certificate verification message that I acknowledge that it is OK to load application. Could this have something to do with it?

Thanks yet again…


I don’t think the security certificate is the problem. What version of Java is installed on the Mac? You can open up terminal and type java -version. Can you post the full error message from the Mac?

I’m getting the same issue. Just installed Ignition 7.7.2… The designer wouldn’t launch from Internet Explorer. Clicking on the link saves the .jnlp file, but it won’t launch.

Even double-clicking the saved file didn’t launch it. I had to use “javaws.exe” from the command line to launch it. I also tried launching in Chrome - same problem.

This is on a fresh install of Windows 7 Pro x64, with Java 1.8.0_25 installed.

When it finally did launch, java gave me an error saying it was looking for Java version 1.6. I told it to run on 1.8 anyway, and so far no problems.

It’s probably a file-type association problem - not sure if it’s unique to my machine or a problem that others are having.

Have you tried out our native client launcher yet? It’s often a better workaround to skip the JWS system altogether.

Where would I find the install for the native client launcher?

On the gateway home page:

Hmm, those don’t show up for me. I am able to see all of our projects, devices, databases, etc. But not those clients.

What version are you running? Need to have at least v7.6

If you have that, then you may need to turn that section ‘on’ in the Homepage config.

FYI. We are running version 7.5.13 (b1571) and the client launchers are available in this version.

Have you tried going to Start>Default Programs>Associate a file type or protocol with a program and making sure the host OS knows to associate .jnlp files with javaws? If it is already set then your only workaround is most likely going to be the Native Client Launchers if you are able to update to the most recent release of Ignition 7.5.