Designer Window Fails to Open

I am have installed the Designer app on my desktop PC. I can reach our Ignition installation but when attempting to open the designer window, I get a window flash on the desktop and then nothing. I see nothing telling in the log. The last thing is the call to start the designer and that is it. Any help would be greatly appreciated.

Java Version: 8 update 281, 64-Bit
Windows 10 Pro for Workstations, version 20H2, Build 19042.844
Windows Firewall: Disabled

What version of Ignition are you using? Are you launching the Designer from a JNLP file or from the Designer Launcher app?

Gateway: Version: 8.1.1 (b2020120808)
Designer Launcher Version: 1.1.1
I have tried to open it from the design launcher app and also created a shortcut from the design launcher. Both provide the same result

Nobody has any recommendations?

Check ~/.ignition/clientlauncher-data/designerlauncher.log for any log messages that might be relevant.

where is this directory? It appears to be a linux directory. I cant find this structure anywhere and neither can windows.

~ means your user home directory, something like C:\Users\Whatever.

Thanks for clarification. Windows couldn’t find it either as the extension was .txt not .log. There isnt’t much in there however. I created a new file and launched again. Here is the result:

INFO  [DesignerLauncher              ] [2021/03/09 08:58:29]: Set initial logging level to INFO
INFO  [DesignerLauncher              ] [2021/03/09 08:58:29]: Updating logging level to INFO
INFO  [GatewayConnect                ] [2021/03/09 08:58:30]: Attempting to connect to gateway
INFO  [LaunchUtil                    ] [2021/03/09 08:58:31]: Starting Java with the following parameters: C:\Program Files\Inductive Automation\Designer Launcher\jre\bin\java.exe -classpath C:\Users\cmerani\.ignition\clientlauncher-data\launchclient.jar -Djavaws.ignition.sso=true -Xms64M -Xmx2048M -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=false com.inductiveautomation.ignition.client.launch.BootstrapSwing 

Okay, now if you copy/paste this whole command into a command prompt and run it what output do you get?

C:\Program Files\Inductive Automation\Designer Launcher\jre\bin\java.exe -classpath C:\Users\cmerani\.ignition\clientlauncher-data\launchclient.jar -Djavaws.ignition.sso=true -Xms64M -Xmx2048M -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=false com.inductiveautomation.ignition.client.launch.BootstrapSwing

I had to CD into that directory then run the java.exe. The following exceptions were thrown:

Exception in thread "main" java.awt.AWTError: Assistive Technology not found:
        at java.desktop/java.awt.Toolkit.newAWTError(
        at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(
        at java.base/$ForEachOp$OfRef.accept(
        at java.base/$2$1.accept(
        at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(
        at java.base/
        at java.base/
        at java.base/$ForEachOp.evaluateSequential(
        at java.base/$ForEachOp$OfRef.evaluateSequential(
        at java.base/
        at java.base/
        at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(
        at java.desktop/java.awt.Toolkit.getDefaultToolkit(
        at java.desktop/javax.swing.UIManager.<clinit>(
        at java.desktop/javax.swing.JPanel.updateUI(
        at java.desktop/javax.swing.JPanel.<init>(
        at java.desktop/javax.swing.JPanel.<init>(
        at com.inductiveautomation.ignition.client.launch.splash.SplashPanel.<init>(
        at com.inductiveautomation.ignition.client.launch.splash.DefaultSplashPanel.<init>(
        at com.inductiveautomation.ignition.client.launch.splash.SplashPanelFactory$DefaultSplashPanelFactory.createSplashPanel(
        at com.inductiveautomation.ignition.client.launch.Launcher.startLauncher(
        at com.inductiveautomation.ignition.client.launch.Launcher.startLauncherInitial(
        at com.inductiveautomation.ignition.client.launch.Launcher.startLauncherInitial(
        at com.inductiveautomation.ignition.client.launch.BootstrapSwing.<init>(
        at com.inductiveautomation.ignition.client.launch.BootstrapSwing.main(
Caused by: java.lang.ClassNotFoundException:
        at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(
        at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(
        at java.base/java.lang.ClassLoader.loadClass(
        at java.base/java.lang.Class.forName0(Native Method)
        at java.base/java.lang.Class.forName(
        at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(
        ... 23 more

Can you follow along the troubleshooting that happened in this thread?

Seems related to having installed the Access Bridge or something.

1 Like

It is always more helpful to address an issue directly especially for those who may search in the future. I believe what Kevin means by looking at this disaster of a reference thread is that the access bridge must be disabled. In order to save anyone else from having to weed through that thread who may be facing the same issue, here is how to disable it.

  1. Navigate to your JRE Bin Directory, mine was (C:\Program Files\Java\jre1.8.0_281\bin)
  2. Execute “jabswitch.exe /disable”

This has finally allowed the designer to open for me