Designer won't launch

When I try to launch the designer from gateway web-launch all I get is the Java startup window with “Java…”, even Java runtime console won’t start.

When I launch the project everything works as normal.

I’m using Ignition 7.7.4 and Java run time 8 update 45

This happened to me last week. Ensure that you do not have Java SE Runtime Environment 8u51. It might have upgraded automatically. I had to uninstall all Java versions then I installed a fresh copy of 8u45. Works perfectly again.

Good luck!

Enabling the java console (it’s an option in Java’s Control Panel entry, somewhere) might give us a little more to go on.

I’m having this same issue.

Uninstalled all Java, cleaned up folders and registry. Rebooted Fresh Installed Java 1.8.45-32bit.

Reinstalled Ignition.

Still doesn’t work.

Running Ignition 7.7.4-32bit on Server 2012R2.

Any Help would be appreciated.



did you delete the local user’s .ignition folder?


1 Like

Just tried that and no luck.

So i tried cleaning and installing fresh again. Here were my steps and status.

Java Console and Logging are enabled.

1: Installed Java 1.8.45 32bit
2: Installed Ignition 7.7.4 32 bit
3: Ran Designer with no issues.
4: Restored Gateway from Backup
5: Runtime App runs fine. Console loads and logs.
6: Attemted to load the Designer: Does not load. Get the Java splash then disappears, Java Console Does not load. No logs or traces are logged via java. Able to see either jp2launcher.exe or javaws.exe popup in the taskmanager, then disappears when the java splash goes away.

I’m in the testing phase of migrating our gateway to a new server. So at the moment we are still up and running, but I’m hoping to complete our migration by the end of next week.

Any other recommendations?



It sounds like you may have settings in your backup that don’t mesh with your new installation. You might want to check the Designer Web Launch settings in the Gateway Settings area. Make sure it supports the correct java versions, has ok memory settings, etc. Try restoring defaults to the web launch settings if yours are different.

If you aren’t seeing the console, the JVM likely isn’t even getting started so something is going on with the launch configuration.

Not sure how/when it was changed, but the Launch Link Script Policy was set to ‘JavaScript’ and not ‘Direct’

Changed this to ‘Direct’ and all is working.


So this issue is back. I’m testing 7.8 and after upgrading, the designer will not launch.

Any thoughts?

Got Connected with Support.

Seems if you are running Java 32 bit you cannot have the designer memory setting higher than 1.0GB.

Ran with 2.0GB setting just fine on 7.7.4 and 7.7.5. 7.8.0 didn’t like it.

Thank you Support team!

1 Like

I had the same behavior only just on the client, the designer worked fine. I could launch clients from other servers just not this one. Not sure the root cause but uninstalling 32 bit java on my laptop solved the issue for now.