Device not connected

I have an Ignition gateway set up with one PLC device (a CompactLogix). I set it up about a month ago and everything was working fine until sometime today when it went offline (the status screen shows the device is disconnected). I can ping the PLC from the same server that Ignition is installed on. I can browse to the PLC’s web page. I can also see the PLC in RSLinx. I tried deleting the device and adding a new one in Ignition. I also tried restarting the gateway service. I am not sure what is going on.

Ignition is 7.2.7.170.

Very strange… I rebooted the server and that didn’t help, but when I cycled power on my PLC everything came back up.

If this happens again call into support so they can snoop around and grab some logs.

It sounds like the processor ran out of CIP connections.

To communicate to a CompactLogix processor a CIP connection is needed. Keep in mind, CIP connections are different from PING and web page requests. I have seen cases where CompactLogix and even other AB processor’s CIP connections are not cleaned up correctly. When the processor has used all of the available CIP connections it will start refusing requests.

What is the CompactLogix firmware version?

Are you connecting through a NET-ENI?

Tom

It is firmware level 16. It’s the highest I can go as this is the DriveLogix version (same as 1769-L35E but embedded in a PowerFLex 700S drive) which doesn’t support anything higher. We are not planning to use this PLC in the future.

I checked the diagnostics on the CompactLogix web page and it showed lots of available CIP connections. Of course that doesn’t necessarily make it true. I changed my device properties to only allow 1 concurrent request. I don’t know if Ignition dropping / adding connections as the leased tags change is what did it or not.