Device(s) connecting then disconnect

I have a couple of devices that will show connecting, and then immediately disconnect. I had one doing it for awhile and wasn’t sure it would respond to modbus anyway. But now I have another one doing the same thing. I have a modbus scanner program that can talk to it without problems. I have two of the same device and one does the connect/disconnect and the other doesn’t. I’m talking to them with Modbus TCP, I even tried swapping the IP address thinking if it was a device issue the problem would move, but it doesn’t. I use a UDT for the tags so they are both using the same tags. I tried removing the tags on the one that connects/disconnects and still have the same problem. Any suggestions?

thanks

What pace are you polling? Many Modbus devices will disconnect an “idle” client if there isn’t some activity at least every ten seconds. Try ensuring at least something is subscribed faster than that.

I’m using the default rate on all the devices, so I don’t think that is it?

It isn’t a device setting, but a tag group setting. The default is one second, though. Do you have at least one tag subscribed?

Yes, I have probably have 250 or so tags. I have a UDT defined for the device and use the same UDT for both devices. I don’t think it’s likely a device issue. I swapped the IP addresses between the 2 devices and expected the problem to swap units. But it doesn’t it and I have another modbus scanner that doesn’t have an issue with reading the one I can’t read. So I’m inclined to think it’s an Ignition problem. I’ve deleted the device and re-added it. I’ve deleted the UDT created for that device and re-added it. I’ve looked thru all the tags on the one that is working, and un-enabled the 1 or two tags that come back as bad, but haven’t had time to figure out why they are bad.