Downloads page

When I visit
I see the page and it disappears after 1 second. Please advise me on how to access the individual module downloads page or if I must go through the module marketplace from now on?

What OS and browser? Any issues with other pages? I’m not able to replicate this in Win7 with Chrome, Firefox or IE11.

I just replicated this in Chrome 31.0.1650.63 running on Windows 7 Pro 64-bit. The page initially shows with the contact form. After clicking the “Skip form and take me directly to the downloads >>>” link below the form, the downloads page displays for a moment and then goes completely blank (white).

No issues loading in:

  • Internet Explorer 10.0.9200.16750
  • Firefox 22.0

I actually remember running into this a month or so ago too; at that time I just tried it in another browser and forgot about it.

Thanks, I’ll let marketing know.

I tried reproducing with various browsers/OSes including build 31.0.1650.63 of Chrome without luck. I’ll add in some additional logging and see if that doesn’t shed some light on it. Those logging changes will be up tomorrow morning.

FYI I just tried this on another PC running Windows XP 32-bit and Chrome version 31.0.1650.63 m and the page loads fine (still goes blank after load on original Win7 64-bit PC which interestingly doesn’t have the trailing m on the Google Chrome version number).

I also found TrendMicro blocking this same page on some computers (this does give TrendMicro block message, not just a blank white page). The reason for the block is the page is opening Google ads between loading the content.

Which led to me trying something else on the PC that blanks the page: pause AdBlock in Chrome… and the page displays fine.

It looks like this page’s method of accessing Google ads is not AdBlock friendly. AdBlock normally does an excellent job of hiding only ads (not the whole page). This leads me to think this page’s coding could be improved.

Is it necessary for this page to access Google ads at all (none are displayed on it)?

avast! is doing the same thing. Chrome Version 31.0.1650.63 m

Ah, it appears that the ‘easyprivacy’ filter (and maybe others) in adblock is keeping google analytics from loading, which for some reason is also not letting the page load… I’ll see what I can do about that. Thanks for bringing that to my attention!

I’ll post back when it’s fixed. In the meantime it looks like you’ll have to pause adblock to open the download page.

You could also download Opera real fast and use it to get the downloads.

Alrighty, I’m pretty sure I’ve got this one nailed. I just pushed out some changes that should take of it. Thanks everybody for taking the time to test different browsers/configurations. Cheers!

Confirmed (for me, at least) working in:

Chrome Version 31.0.1650.63 m
Firefox 26.0
IE 10.0.9200.16521
Opera 18.0.1284.68

You’re welcome Michael–and thanks! Adblock in Chrome 31.0.1650.63 and TrendMicro are both happy with it now.