EAM Agent Upgrade Needs Commissioning

I tried EAM Agent Upgrade to upgrade some gateways from 8.1.26 to 8.1.32. EAM controller was upgraded to 8.1.32 successfully first via installer. EAM queued the upgrade on 8 gateways and I told a couple to go ahead. They said upgrade was successful, but commissioning was required.

No problem, I thought. Go to agent gateway web page and commission. Except the agent gateway web pages are not prompting to commission and agents are still running 8.1.26. Restarting the gateways doesn't change this. Neither does restarting Windows. Is it possible EAM upgrade does not work in trial mode? (EAM is in trial mode on all gateways, time has not expired.) Or am I missing something else?

It's not a trial mode issue. It worked on another gateway in trial mode. The difference is the Windows service account Ignition runs as on the one that works has full admin privileges. The Windows service account Ignition runs as on the ones that do not work (most of them) has only the minimum privileges required for the Ignition gateway to function. Do we have to give the account Ignition server process runs under full admin rights? What is the minimal it would need for EAM remote upgrade to function?

I have noticed that this agent needs commissioning thing pops up every once in a while, but have never noticed a pattern. Our service accounts have not had their permissions changed in years. It seems to be luck of the draw.

I don't understand the point of the commissioning process on the agent. If the intention is to accept new terms and conditions, this can happen on the EAM controller.

Having to visit each gateway reduces the functionality of EAM.


I agree. It would make much more sense to accept terms & conditions in the location where we are running the installation from--the controller.

At the start of the process I was thinking if this works maybe we're getting to the point where it's worth licensing EAM. The agent upgrade (or lack thereof) user experience discouraged the sale, rather than encouraging it.

For what it's worth, all of my gateways have the EAM licenced. That doesn't fix it

1 Like