Easy Chart and timezones

#1

My time tagged data is stored in the db (postgres) as GMT.
When it gets displayed on the easy chart, I want it to display in local time.

0 Likes

#2

You should just have to set the project’s “Time Zone” property (in the designer, click on the root node of the project browser and it will appear in the property table) to “Client Timezone”

0 Likes

#3

nice! I’ve heard people ask to configure it both ways (plant perspective versus local).

0 Likes

#4

Thanks! Replying with the word “EasyChart” so if someone else searches “EasyChart timezone” (no space between “easy” and “chart”) they’ll find this. Gateway timezone had worked well before so I’d never paid attention to this setting and forgot it existed.

Today I ran into this problem when making a duplicate of a project on a gateway in a different timezone than the EasyChart data was from. Setting project to the actual timezone means clients running this project off either gateway see the time per the zone it was recorded in (as desired in this case).

0 Likes