Easy chart does not poll

I have an easy chart that I setup in FPMI. I have imported it to Ignition and now it doesn’t want to poll.

It is historical, with 4 DB pens. I have created 4 controls to select the points to chart. I have code to update the where clause for each pen. Everything else should be ‘right out of the package’.

I have verified that the dataset is getting updated with the correct where clause. I have changed the chart mode, (manual,historical,realtime). I have toggled auto apply. I have changed the pool rate. All while watching the database connection status and nothing I do causes queries to hit the database.

I have also verified that data exists in the database for the selected point and time frame using the cool little Query Browser (great addition that)

What am I missing? :cry: :imp: :cry: :question: :question: :exclamation: :exclamation: :exclamation: :exclamation: :cry:

Are you getting any errors or are the queries returning 0 rows?

If the query is returning no rows, you need to double check that the where clause isn’t getting messed up.

If there is an error, it should have a little more information about what is going wrong. If you can post it, we can help you narrow it down. Otherwise, you can do the following:

  1. Check that the default datasource for this project is pointing to the correct database.
  2. Check that the datasource traffic is turned on.
  3. Add a table component to that screen and bind the “data” property to a “select *” query for the selected point and time frame.

The Easy Chart does not poll in historical mode, because it would be wasteful. It didn’t in FactoryPMI, and it still doesn’t in Ignition Vision. It will poll in Manual and Realtime mode.

Robert, I am not getting any errors. It looks like it is not querying: no data, no errors, no spinner no signs of life.

Carl, I know that historical doesn’t poll. When is it supposed to refresh? In FPMI I get a spinner whenever I change the date selector or the where clause for a pen. In Ignition I have yet to see a spinner.

I started to create a data table as per Robert’s suggestion. That is when I noticed the date format in the properties does not match the format shown in the database(Postgres). When I ran a query with the format shown in the properties (using the sql browser tool) the query timed out. When I used the correct format the query worked fine.

I have compared the properties for the chart in FPMI and Ignition and they are identical.

I had this same issue last week. Not totally sure what the problem was, but its working now. PM me tomorrow (Monday), and ill give you a hand

Thanks Kyle,

Glad to see it’s not just me. Left a message for you.

We resolved the issue. While no tag or calc pens are being polled, the dataset needs to have the proper structure. Once the structures where put in place, everything worked fine


Kyle solved it for me. As I was only using DB pens the dataset for tag pen and calculated pens was empty. These have to be filled in. Open the easy chart customizer (ctl-U) and click OK.

Thank you Kyle, Carl and Robert

Wow, this is a great example of the strength of our user-community. Thanks for helping out Kyle!

I’ve entered this in as a bug to let the Easy Chart be more lenient when its datasets aren’t structured the way it likes.

:scratch: I can’t replicate this one - can someone give me a set of steps that causes this behavior? I added DB pens, and then did various things to make the other datasets blank, and nothing affected the chart’s behavior.

I think the big setup for this one is:
create a project on FPMI
add easy chart
configure the pens to use a db query
port to Ignition
check that only dbpens have columns in the dataset.

It could also be that the easy chart customizer does other stuff beside populate the pen datasets and that is what really fixed it.

This was fixed in 7.0.9