Easy Chart Same Pen Name Different Group

We are using click to chart in FactoryPMI and I am moving the project over to Ignition. I found that when pens are added with the same exact name, but in a different pen group there is a conflict. for example in the picture there are two pens named “Feed Flow”. If I click one of the feed flow pens both become checked and the chart gets a red box around it. in the designer I receive a SQL error stating that one of the columns does not exist in the database table.

some how the chart no longer knows how to differentiate between pens in two different groups.


If you have a lot of pens then this may be a hassle but I solved this by having unique names. I typically create a unique name for all pens in a given machine anyway but when I added similar machines I ran into this. I ran an update query to modify the names adding a prefix to identify the machine.

Could this please be added to the bug fix list? There does not seem to be any where I can control what SQL queries the EasyChart creates. In my example below it should be making a query with column DigesterFeedTemp on table tblWasteWaterDigester and column EqualizedFeedTemp on table tblWasteWaterEQ.


Yes, I’ve added this as a bug. We’ll look at it soon, and I expect that it’ll be fixed by the next update.

Regards,

The easy chart expects pen names to be unique. I don’t think the easy chart never accepted multiple pens with the same name to the best of my knowledge - was your old click to graph implementation using the classic chart perhaps?

Anyhow, like Colby said, this has been added to the list to be fixed.

I am using an easy chart. The icon has a graph with a magic wand. Also when i right click the chart in the designer it gives me the easy chart customizer under component customizer.

Huh, this must have changed from early versions of the easy chart then. I’ve got the ticket in, but it’s a pretty serious change. Pen names are used as column names, and column names must be unique, so it’ll take some doing for us to do this safely.

This was fixed for 7.3.