Easy Chart Tag Issues

Hey guys,

I found a couple of problems with adding tags and adding properties into the cell update property binding.

I was creating a easy chart window today (I haven’t done it for a few versions so I don’t know when this happened) and when I clicked on the tag icon to add a tag for a pen I was presented with a blank screen. If I type in the tag path manually it works but I can’t select it from the tag selector:

The other problem I found was when I tried to edit the tag names with the cell update property to make it dynamic. I added the row but the tag path did not populate down into the cell update value pane, I again had to type in the address manually. Then I tried to add in the property to make it dynamic and I could select the property with the property selector but it would not put my selection into the cell update field. I had to also type in the property by hand. Everything still worked but it just made it a lot harder and more tedious.

I’m running Ignition version 7.4.2 (b953)

I’m not able to reproduce these issues. Can you call into support and have them look at it?

Take a look at the log in the gateway right after you try to open that screen. Does it say something about an error parsing a tag path?

We recently saw that an invalid tag path in the historical table could prevent browsing for all historical tags. How could it get there? Apparently through CSV import. So, if you have an entry in the “sqlth_te” table whose path includes an illegal character (in the other case it was “=” and “&”), it could be causing this.

I believe 7.3.7 fixes it to only affect the particular tag, instead of everything.