Eco Graph no anonymous token policy found

I am trying to connect Eco Graph T RSG35 OPC UA Server into ignition and I am getting the error shown below:

java.lang.Exception: no anonymous token policy found
com.digitalpetri.opcua.sdk.client.api.identity.AnonymousProvider.lambda$getIdentityToken$110( Source)com.digitalpetri.opcua.sdk.client.api.identity.AnonymousProvider.getIdentityToken($activateSession$113( Source)java.util.concurrent.CompletableFuture$UniCompose.tryFire(Unknown Source)java.util.concurrent.CompletableFuture.postComplete(Unknown Source)java.util.concurrent.CompletableFuture.complete(Unknown Source)com.digitalpetri.opcua.stack.client.fsm.ConnectionStateFsm.lambda$null$2( Source)java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(Unknown Source)java.util.concurrent.CompletableFuture$ Source)java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)java.util.concurrent.ThreadPoolExecutor$ Source) Source)

My Ignition version is 7.8.1. I have not created any passwords at the moment. Any help would be appreciated.

This error means you haven’t configured a username and password for the connection but the server does not allow anonymous access.

Hey Kevin,
Thanks for the quick response, but I called the inductive automation and marcus and I resolved the issue by installing the opc core components. First we tried to do the allow anonymous access but that did not resolve our issue. If we can incorporate this component in our new version it will be really helpful for all of us.

OPC core components doesn’t have anything to do with OPC UA, it’s for OPC classic.

Not sure if you switched to a classic/DA connection to get it working or what.

Yeah I did move to OPC Classic because when we tried using top server quick client it was able to make connection with the Eco graph using the OPC DA connection.