Edge OPC UA Omron FINS/TCP connection, tag status showing uncertain

Hi All

I am working on Ignition Edge, PLC = CJ2M-CPU35, using Omron FINS/TCP driver.
Tag connections are fine, able to read and write.

However sometimes when gateway and plc are powered off and powered back, all the tag status would become uncertain, with the circle ? icon, even though device connection status is Connected.
Have tried to enable/disable the connection, on/off the plc, the tag status still remains as Uncertain.
The only way is to restart the gateway(ie restarting the pc).

Tried searching through the logs, but could only identify FinsWriteRequest warning:

java.util.concurrent.TimeoutException: timed out after 2000ms
at com.inductiveautomation.omron.fins.client.tcp.FinsTcpClient$sendCommand$timeout$1.run(FinsTcpClient.kt:103)
at io.netty.util.HashedWheelTimer$HashedWheelTimeout.expire(HashedWheelTimer.java:672)
at io.netty.util.HashedWheelTimer$HashedWheelBucket.expireTimeouts(HashedWheelTimer.java:747)
at io.netty.util.HashedWheelTimer$Worker.run(HashedWheelTimer.java:472)
at java.base/java.lang.Thread.run(Unknown Source)

Could someone advise how should i go about troubleshooting the problem?
Many thanks in advance!

What version is this? IIRC, there was a bug fixed recently in Ignition’s OPC/UA server that was responsible for similar behavior.

Hi Phil, im using Edge 8.0.16.

Saw this post and realised they have the same issue too.

You might try upgrading to the latest 8.1.x version.

8.1.5 contained a fix for an issue that sounds similar:

Fixed a bug that caused tags to get stuck with Bad_NotConnected or Uncertain_InitialValue quality on startup or reconnect.

I don’t know for certain whether that affected 8.0.x versions or not.

However if the problem is just that the device isn’t responding, which your original post with the timeout issue is showing, then you just have something misconfigured either in Ignition or on the PLC side.

Hi Kevin, thanks for replying.

1.The edge is connected to a mqtt server, version 8.0.16 as well. If i upgrade the edge to 8.1.x version, would there be any… ‘mismatch’ or causing any conflict in the communication?

  1. Do you mean that the log i posted indicates that the device is not responding?

There shouldn’t be… but you can always take a backup (installer should do this as well) and revert to 8.0.16 and restore it if things don’t work.

Okay, will try upgrading the version, thank you for the advice!

From the log that i have posted, do you mean that it indicates that the device is not responding? meaning is not a version issue?

Well, a timeout is not a version issue, but if things are generally working except sometimes on startup or reconnect there is an Uncertain quality that sounded like an issue we fixed.