Edit Conflict

I changed some of the memory settings and default datasource on the gateway. Launched designer and tried to open any window and received the error “Edit Conflict” “Unable to retrieve lock for resource “window name I was trying to open” The resource has been changed. Please update your project.”

Clicked on file, update project and same error is displayed.

Changed all the settings back. Same error.

Have you tried re-launching the designer?

Yes, even from different machines.

What about restarting FactoryPMI or Ignition service?

Getting this message on system console after restart of server:

2011-03-29 10:03:26AM INFO Starting Coyote HTTP/1.1 on http-8443 Http11BaseProtocol
2011-03-29 10:03:26AM INFO Cluster State := MASTER ClusterManager
2011-03-29 10:03:35AM ERROR USB dongle error: ERROR 33: Communication error between application and local HASP LicenseManager
2011-03-29 10:03:35AM WARN USB HASP driver problem detected. Skipping future hardware key polling. LicenseManager

Seems to be a security issue. I did add a user yesterday. When I create a new project can edit all I want. When I copy the old project to a new project get the same error.

Is this FactoryPMI or Ignition?

Sounds like something is wrong with that project - can you send it to us?


File is a little over 5Mb. Where should I send it as it will not attach.

I increased the max file size to 10. Try uploading it again here.

Still giving me the 2Mb limit.

[quote]The attachment’s file size is too large, the maximum upload size is 2 MB.
Please note this is set in php.ini and cannot be overridden. [/quote]

Alright sorry try it once more.

Still don’t have enough room. max is 5 MiB.

Project is 5188 kb.

Saving the project as a different name works. Editing can be done.

Uploading a file over 5 MB works for me. Oh well sorry about the problems. You can try zipping it up if you want.