Editng Device on Gateway Error

I have attached a snippet of my wrapperLog that contains an exception that occurs occasionally when editing an attached device via the gateway. This only started happening after upgrading to 7.2.x. Currently I am running 7.2.4-beta3. When it happens, the gateway shows that an Internal Error has occurred and I have to attempt the edit again. Sometimes it will happen multiple times in a row.
Error.txt (14.1 KB)

How odd. Did you have the mobile module installed and then remove it by any chance?

Yes, since it comes default with the new versions.

I just upgraded to 7.2.4 and have the same problem.
Error_2.txt (14 KB)

I can’t seem to reproduce this error.

Out of curiosity - try a different web browser and see if it exhibits the same behavior. I think it might be the website hanging onto your session with the old mobile settings panel in it? If so, clearing the cookies on your web browser might fix it.

I still can’t seem to reproduce it however…

I tried Firefox, Chrome, and Internet Explorer. Cleared all browsing history on all three. Was able to reproduce the error with all three. Basically, I edited the browse timeout on a device and saved until the error occurred.

Error_3_IE.txt (14 KB)
Error_3_Chrome.txt (14 KB)
Error_3_Firefox.txt (14 KB)

This time, it occurred when attempting a refresh browse.
Error_5.txt (28.4 KB)

It seems like the mobile module is “partially” installed in your system. e.g. the config menu structure is trying to load that module’s configuration page, but the module itself isn’t actually present.

Can you do this and see if you still see the problem:

  1. Shut down Ignition
  2. Ensure that the file [tt]Mobile-module.modl[/tt] is not in [tt]%INSTALL_DIR%/contexts/main/modules[/tt]
  3. Restart Ignition

I did find a problem that could cause this and have it fixed for 7.2.5

Tried on both of my servers, no avail.

Is there any way you could call in on Monday morning and demonstrate this to tech support?

Yes, I could do that. To bypass the problem on my production server, I just reinstalled the mobile module. Before I call in, I will make sure that the problem still exists, since even on my development server (without the mobile module installed) I haven’t been getting problems lately.