Email Notification Fault

#1

I am trying to set up an email notification but at present I am getting this error:

4:53:54 PM EmailNotificationProfile[Email] [hostname=10.68.0.84,port=25] Error sending message to user ‘usr-prov:default:/usr:DNally’.

javax.mail.MessagingException: Could not connect to SMTP host: 10.68.0.84, port: 25;
nested exception is:
javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1972)
at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:642)
at javax.mail.Service.connect(Service.java:317)
at javax.mail.Service.connect(Service.java:176)
at javax.mail.Service.connect(Service.java:125)
at javax.mail.Transport.send0(Transport.java:194)
at javax.mail.Transport.send(Transport.java:124)
at com.inductiveautomation.ignition.alarming.notification.email.EmailNotificationProfile$EmailTask.run(EmailNotificationProfile.java:340)
at com.inductiveautomation.ignition.alarming.notification.email.EmailNotificationProfile$3.run(EmailNotificationProfile.java:193)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
at sun.security.ssl.InputRecord.handleUnknownRecord(Unknown Source)
at sun.security.ssl.InputRecord.read(Unknown Source)
at sun.security.ssl.SSLSocketImpl.readRecord(Unknown Source)
at sun.security.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at sun.security.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at com.sun.mail.util.SocketFetcher.configureSSLSocket(SocketFetcher.java:548)
at com.sun.mail.util.SocketFetcher.createSocket(SocketFetcher.java:352)
at com.sun.mail.util.SocketFetcher.getSocket(SocketFetcher.java:233)
at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTransport.java:1938)
… 11 more

0 Likes

#2

It looks like you’ve got the wrong combination of having SSL enabled and port - if you’re supposed to be connecting with SSL try port 465 and 587.

0 Likes

#3

It turn out the problem was actually authentication or rather I did not need to add username or password, which I think is strange but it worked so there you go.

0 Likes

#4

It works on me like a charm after I set usename blank

0 Likes