Email Notification profile

Using a few different SMTPs
None have worked for me.

I have an imail hostname
default port 25
and there is not a username or password.
In the pipeline setup I have the account address in the FROM selection.
I’m emailing to the users group which I am a part of and my email address is a gmail one.
Do I need something more?

Is there any way someone could get me started using gmail or something common so I can figure out what I’m doing wrong?

One place to start might be to put the Notification Block into ‘Test Mode’ and then watch the console when you trigger the alarms to see who the message would have been sent to. If this all looks correct, then you can troubleshoot your email profile by searching for ‘EmailNotificationProfile’ on the Levels tab, turning the profile to DEBUG, and attempting notification again.

Time Logger Message
11:32:39 AM EmailNotificationProfile[EmailNotification] [hostname=tls://,port=465] Error sending message to user ‘usr-prov:Security:/usr:aj’.

javax.mail.MessagingException: Unknown SMTP host: tls://;
nested exception is: tls://
at com.sun.mail.smtp.SMTPTransport.openServer(
at com.sun.mail.smtp.SMTPTransport.protocolConnect(
at javax.mail.Service.connect(
at javax.mail.Service.connect(
at javax.mail.Service.connect(
at javax.mail.Transport.send0(
at javax.mail.Transport.send(
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)
Caused by: tls://
at Source)
at Source)
at Source)
at Source)
at Source)
at com.sun.mail.util.SocketFetcher.createSocket(
at com.sun.mail.util.SocketFetcher.getSocket(
at com.sun.mail.smtp.SMTPTransport.openServer(
… 11 more

No luck.

Why do you have a ‘tls://’ prefix on the hostname?

I tried other names and ports,
nothing has worked yet. … -settings-

I dropped the prefix on the host and kept the port.
It worked now and I am getting emails from gmail.