Email Settings in 7.8.0 (b2015101414)


It seems that the new gateway email settings is not taking in account the port setting.
IE, when I configure a working smtp account with port 465 (and of course working email sender and password :slight_smile:), the error message is the following when using test :

[quote]com.sun.mail.util.MailConnectException: Couldn’t connect to host, port:, 25; timeout -1;
nested exception is: Connection refused: connect[/quote]
Of course, no firewall or virus checker on this machine for testing purpose and the account is working in a regular email client.

Any idea?


Some SMTP servers (like gmail) don’t use a dedicated port for SSL/TLS and will give this kind of error in 7.8.0. In 7.8.1 we added another setting to deal with this properly. :blush:

A 7.8.1 beta should be up soon (this week maybe?), but naturally, all the beta caveats apply. Another option would be to (for now) use a mail server that does use a dedicated port and change back to your preferred server when you upgrade to 7.8.1

Hi Kathy,

Thank you for the reply.
What is strange is that this email account is working with the Email Alarm Notification (port 465 with TLS activated).
What is the signification of the 25 in the error message “Couldn’t connect to host, port:, 25; timeout -1;”?


The SMTP server sent a message back saying it couldn’t connect on port 25, even though you tried to connect on 465. This happens when there’s no dedicated SSL/TLS port.


Thank you.