"Enter" key missing in mobile project

We have a project that has numeric input fields that require you to hit enter to accept the value (“commit on focus loss” is false). On iPads running that project through the mobile module, when you edit that field, the on screen numeric entry does not have an “enter” key. Has anyone else run into this and is there any sort of work around without enabling “commit on focus loss”?

Can an enter key be added to that touchscreen keypad?

What version of Ignition are you running?
Does this happen only on iPads? other iOS devices? Android devices?

Ignition 7.6.4

It happens on every device I have tried. First noticed on ipads, but you can replicate it just by pulling up the mobile project on a PC. The pop-up on screen keyboard does not have an enter key


Thank you for bringing this to our attention. I was able to reproduce what you described. I have added a ticket here to have this feature/functionality added. I will update this forum thread once it has been updated.

This has been added for 7.6.5

Just installed v7.6.6. Still not there.

Note that this change only applies to the numeric keypad that pops up for input components that require numbers, not the regular keyboard. Which one are you using?

‘Numeric Text Field’ It works as expected launching the mobile app on a PC, just not the iPad I’m using. It’s going through an OS update now.

Now it’s working. :thumb_left: