Error 193 - Not a valid Win32 application

Hi,
Has anybody come across the error 193?
It occurs when trying to start up the service on the ignition Gateway control utility.
I am running the 64 Bit application on a 64-bit laptop.

Someone just posted this on our internal message board which sounds relevant to your problem:

After Windows Feature update Windows 10 version 1803 has been installed. Ignition service will no longer start automatically on OS startup. In windows event viewer log you will see the following error:

" The Ignition Gateway service failed to start due to the following error: Ignition Gateway is not a valid Win32 application."

This issue will be fixed in Ignition 7.9.8

In the meantime, there is a hotfix that you can apply to work around this issue. You can replace the ‘IgnitionGateway.exe’ located here ‘C:\Program Files\Inductive Automation\Ignition’ with a new .exe file found here:

Link: https://files.inductiveautomation.com/support/windows10_1803_hotfix/windows-32/IgnitionGateway.exe

Link: https://files.inductiveautomation.com/support/windows10_1803_hotfix/windows-64/IgnitionGateway.exe

In addition to the hotfix the service can also be started by running the following command via a command prompt: “c:\Program Files\Inductive Automation\Ignition\IgnitionGateway.exe” “c:\Program Files\Inductive Automation\Ignition\data\ignition.conf”

This will resolve the startup issues until the fix is released in Ignition update 7.9.8

4 Likes

My server updated and now I can’t start the gateway back up due to this issue. I also cannot open the linked files due to a security error message about the security certificate.

How else can I get this going again! I need to get Ignition back up and running.

edit: ok I was able to override the error and download the file. Got the gateway back up and running. Thank goodness for this thread!

1 Like