Error 400 Bad Request

Every time I try to launch my project using the IDP authentication strategy, I’m able to type my username and password but after I log in I get this:

HTTP ERROR 400 Bad Request

URI: /data/feerate/callback/ignition
STATUS: 400
MESSAGE: Bad Request
SERVLET: DataRoutes

http://localhost:8088/data/federate/callback/ignition?code=Pe9jeyli8HfR49NJuGk-Wn5aMjrTj_ZhCDVmGDHBV8M&state=-CR-5VmRh_O0K2BdR5ppYcUa1ameWsoMbS_XjNfT_Qs

In which version of Ignition are you running into this issue?

What part of Ignition are you logging into? (i.e. Perspective? Gateway Web Interface? Designer? Vision client?)

What kind of device are you on? (i.e. Perspective Mobile App on iOS/Android, Perspective Workstation, web browser such as chrome / safari / FF on windows?)

Do you have a setup involving multiple Gateways behind a load balancer?

  1. Version 8.1.0
  2. Designer
  3. Web browser (Chrome)
  4. I don’t think so.

if you set gateway logger gateway.FederationRoutes to debug level, and trigger the failed login error again, do you see any messages in the gateway logger?

I see this message now:

FederationRoutes 16Feb2021 16:09:54 Unable to parse the error redirect URI from the relay state JWT

I’m using an ignition IDP

Are you sitting on the login page for a while? I think you only have about 2 minutes from the time you trigger the login in the designer to the time you complete the login before the login request times out.

I’m also wondering if there are some browser cookie issues at play here. Did you recently access the Gateway in your web browser using https:// (SSL/TLS)? If so, and if force secure redirect is not enabled in Gateway Web Interface > Config > Networking > Web Server, and if you are trying to login to the designer over insecure http://, I could see how your web browser might refuse to honor cookies on the insecure connection. Perhaps try clearing the cookies for the hostname(s) or IP(s) the Gateway is running on from your web browser and try again. Or use one protocol (preferably secure https://) in all your interactions with the Gateway…

No, I’m logging in as soon as I launch the project.

I tried clearing the cookies for the hostnames the Gateway is running on from my web browser. I also tried accessing the gateway with both https:// and http:// and I still get the same error. This error happens regardless of the browser I use, either Chrome or Firefox