Error connection Ignition 7.9.6 to Kepware

Hello, I am trying to establish an OPC-UA connection to Kepware from Ignition. When trying to connect in Ignition, I keep getting the following error:

UaException: status=Bad_SecurityChecksFailed, message=An error occurred verifying security.
at org.eclipse.milo.opcua.stack.client.handlers.UaTcpClientAcknowledgeHandler.onError(
at org.eclipse.milo.opcua.stack.client.handlers.UaTcpClientAcknowledgeHandler.decode(
at io.netty.handler.codec.ByteToMessageCodec$1.decode(
at io.netty.handler.codec.ByteToMessageDecoder.callDecode(
at io.netty.handler.codec.ByteToMessageDecoder.channelRead(
at io.netty.handler.codec.ByteToMessageCodec.channelRead(
at io.netty.util.concurrent.SingleThreadEventExecutor$
at Source)

Someone on a somewhat similar post suggested that doing an edit/save would work but it hasn’t for me. I’m not really sure what to do and I would really appreciate some help! Thanks in advance!

You probably need to go into Kepware’s OPC UA configuration and mark Ignition’s client certificate as trusted.

Also, I’ve tried playing around with the security settings within Kepware, reissuing instance certificates, and enabling anonymous login. Nothing has worked.

Hey Kevin, appreciate the speedy response. The client certificate is marked as trusted. I’m not sure whether this is an issue with Ignition or Kepware at this point.

The error code is coming from Kepware so you probably need to focus your efforts there. Kepware support might be able to tell you why it’s happening, but there’s no additional information available to Ignition.

Sounds good. Appreciate your advice!

You do need to reinitialize Kepware after making any of those changes.

You also need to restart Ignition if you did any kind of refresh in the Ignition OPC UA client certs.