Error during browse

Hi,
My first post.
I am just starting to evaluate FactorySQL and am trying to connect to my PLC’s. I am running RSLinx on my PC, but when I try and browse it for a PLC I am getting an error “Error during browse”.
When I go into RSLinx and OPC I do not see any of my PLC’s with the “Locked” symbol beside them. I am wondering if I need to set up comm’s. As mentioned I do see the RSLinx OPC and PLC’s in the FactorySQL browser.
Any help would be great.

Thanks, Conor

Hi-

There are two common things that often trip people up when getting started with RSLinx:

  1. Version of RSLinx: Not all version support OPC communication. It must be the Professional, Gateway, or OEM version. Basically, anything except the “Lite” version. So check that, and make sure it’s activated.

  2. You must have a “topic” configured, and have it linked to the device. Since you said you were looking for the lock symbol, you might have already done this, but double check. To create a topic, you would go to DDE/OPC->Topic Configuration, click “New”, then browse on the right side to your PLC, and hit “apply”. If you already have a topic, make sure it’s correctly linked to the device- when you click the topic, the device should be selected on the right side. If nothing happens, browse to the device, select it, and hit “apply”.

After making changes like this, you should hit the “refresh opc servers” button in the FactorySQL toolbar. If it still doesn’t work, look in the FSQL error log (Help->Log Viewer) for more information about the error. Somewhere in the error message you should see an error code that could help like E_ACCESSDENIED or E_INVALIDLICENSE.

Hope this helps!

Hi,

For the life of me I can’t get it working.

I see 3 OPC’s in the browse pane.

  1. KepServerEx
  2. RSLinx OPC
  3. RSLinx remote OPC

I keep getting the error during browse errors.

I did see the topics at one stage today in the RSLinx Remote OPC, but when I tried to drill down into one of the topics it failed.

I also keep getting Windows Installer “Preparing to install” coming up on the screen.

Edit:

Sorry, I am running RSLinx Classic Gateway and have the topics set up in this

As a direct result of trying to browse? I’ve never seen this before, and if it’s not just coincidental, could indicate some sort of install problem.

Can you connect and browse Kepware? After erroring out, are there any messages in the error log that might shed some light on what’s going on? If in doubt, feel free to export the error log and send it to support AT inductiveautomation.com

Also, one thing you might try (just for troubleshooting purposes, not necessarily long term) is follow the instructions in this post to run FSQL as an application. If it works as an application it could indicate some DCOM security stuff that might need to be tweaked.

Regards,