Error executing table data maintenance task

I am using Ignition 8.0.14 and getting the following error in the logs, it seems to be happening every hour.
How to fix? tried to change the locale to English US, it did not help.
Thanks in advance.

I suspect this is a bug that we fixed for 8.0.15 - unfortunately, I’m not sure it will retroactively fix your history. You should upgrade, then change the settings for the SQLite driver to ensure it’s using the ‘SQLite’ translator record, instead of the ‘generic’ (one part of the fixed bug).

The background is that SQLite doesn’t have a true date/time type - so earlier versions after we introduced the seeded SQLite JDBC configuration incorrectly end up using strings to store date/times. After the bug fix, we’re using integers to store Java timestamps ‘directly’. However, that change won’t upgrade your existing SQLite DB - so you might need to get in contact with support to look into migrating your existing history (if you care about preserving it).

1 Like

Thanks Paul for the answer, is it possible to know which table is involved with this error, I can`t find a reference to the table or the database name, also does this bug affect the internal db (used by audit tracking and alarm management) or only the external SQLite Db (for my case used for short term history storage).
Thanks in advance.

This line in the stack trace implicates FactorySQL, which is the legacy name for transaction groups/the SQL Bridge module. Unfortunately, it doesn’t narrow it down any more than that - but take a look through your transaction groups for something that’s scheduled to automatically delete records older than some time period - that’s ultimately what’s causing the issue.

1 Like

Hi Paul, I tried version 8.0.15 and 8.1.1 RC1 and I am still getting the same issue, Change the property in the Sqlite driver to Sqlite but still getting the same error, I checked the timestamp in the table and it is an integer value as expected, could be a problem with the transaction group delete request, indeed I am using a Historical TG to log the data locally using Sqlite as a data source and I enabled the delete records older than option.

Transaction groups don’t have an option to store the row timestamp as a long integer. Which means you’re probably not going to get this to work with SQLite.

Not a clue if this will work, but you could try adding this to your ‘Extra Connection Properties’:
date_string_format=yyyy-MM-dd HH:mm:ss


It works great! Thanks for your support.

1 Like