Error HTTP 403 when launching config page


I’ve install FPMI and FSQL on a new laptop with Vista, disabled firewall and so.
I can launch designer, gateway status but launching config send me always on a FPMI page :
HTTP Status 403 -

type Status report


description Access to the specified resource () has been forbidden.
FactoryPMI Gateway/1.8.7

What’s wrong with my config ?

I’m going to sleep now.


Nothing is wrong with your configuration! FactoryPMI has the ability to restrict communication by IP address range of various sections. By default, the Configuration section of the Gateway is restricted to only allow communication with - the local machine. This is set up this way for tighter security.

To change these settings, go to the machine that the Gateway is installed on, and change the settings under System > Setup, and change or disable the IP restrictions for the Setup Site (aka Configuration Section)

Hope this helps,

Hi Carl,

I understand what you explained to me, but the point is that this is a standalone installation and I cannot reach the configuration page.
See the resulting page below :

or bigger here … 918&size=o.

Any idea ?

Ah, well, that definately changes things.

It is possible that you accidentally changed the ip restrictions for the setup site, effectively locking yourself out. It is also possible that there is some bug in the IP restriction feature.

In either case, you can disable this feature using the Monitor FactoryPMI Gateway utility found in the FactoryPMI Start menu folder. One of the configuration actions you can take from this utilitiy is to remove the IP restrictions. (you will have to restart the FactoryPMI service for this to take effect). Why don’t you try this, and report back as to whether or not it fixed the problem?

If it did, please let me know what the setting was for Setup Site: Allowed Addresses.


What should I say ? you have think to every situation one can have !
This tips has solved my problem. Now I have to find how this happened while it was in that situation just after setting up FPMI and FSQL.

Thanks a lot.


Restrict Connexion IS NOT checked
Allowed Addresses is

More strange is that I can launch Config Page from FPMI gateway control app BUT NOT from main FPMI lauch page at localhost:8080/.

Well, it seems that in this configuration (VISTA + JAVA Version 1.5.0 (build 1.5.0_06-b05)), the STOP/RESTART button of FPMI Gateway control applet does not work.

I did the restart from within the gateway config page.

Maybe you should start testing with Vista as laptop and workstation start to ship with it installed.

Thanks again.

Ok, about this

[quote=“ideas@merignac”]Restrict Connexion IS NOT checked
Allowed Addresses is[/quote]

The restrict connection is not checked because that is what you did when you ‘removed the ip restrictions’ in the gateway monitoring utility.

The allowed addresses is set up correctly. My guess is that the ip address resolution has changed in Windows Vista, and is breaking the restriction feature. For instance, this feature makes sure that the incoming request matches the ip address restriction. Maybe in Windows XP, if you were on the local machine, that address looked like, but in Vista, it looks different (to the FactoryPMI Gateway).

As for the start/stop button of the control utility, this must also be a Vista incompatability.

We currently don’t officially support Vista as we haven’t been able to test with it yet, but plan to do so soon.

Thanks for your patience,