Error: InternalFrameActivated

Hello,

When the popup window opens up and while I start typing number in the text box, below error is shows up. When I close the error box, it works okay. Why does this happen? Please help me out with this. Thanks.

Here useradd is the name of the new window that poped up.

Message:
Error executing script for event internalframeactivated on component useradd

Details:
Traceback (most recent call last):

File “event:internalFrameActivated”, line 1, in

AttributeError: ‘NoneType’ object has no attribute ‘requestFocusInWindow’

1 Like

It sounds like the text box has some script in it’s Key Typed or Key Released event and in that script you are trying to call requestFocusInWindow for a component that is not being correctly identified.

I would look at the script for the text box and of you don’t spot the problem then post the script here and we can look at it.

I figured out solution. Thanks.

Have the same issue and do not know have to fix it.
I created a script for my main window from InternalFrameActivated:
system.gui.getParentWindow(event).getComponentForPath('Root Container.BarcodeScanner.longValue').requestFocusInWindow()

I get the same error.

The component that I used in this script is a numeric text field and its value is bound to a memory tag.

Is .longValue really the component name?

It is the component type. I selcted from the script window and it auto generated. This component is bound to a long value.

I already told you, it should be

system.gui.getParentWindow(event).getComponentForPath('Root Container.BarcodeScanner').requestFocusInWindow()
1 Like

Thanks a million! It worked!!!