Error launching application: SocketTimeoutException:

I get the error “Error launching application: SocketTimeoutException: connect timed out” when I try to launch Designer or Ignition from a system that has been working. Prior to this error occurring, I just upgraded from 7.6 to 7.7, and I also changed the CD-key for this machine. After those two changes, it no longer works. I can see from the trace that it is trying to communicate on port 80. This system operates using SSL on port 8043. There is a firewall in place that I don’t have control over that blocks port 80. Is there a setting that will prevent it from trying to contact port 80. On the gateway settings, I have set it up for SSL, so I don’t understand why it is sending the request over port 80. I connect to the gateway using port 8043, and the line before the failure shows as CacheEntry on port 8043. Two lines later, Connect Step[attempt 1] shows connecting to port 80.

I forgot to mention that I have tried connecting using multiple computers, and different browsers with the same error. I also can connect if I use a browser running on the gateway computer.

When an Ignition client makes contact with the Gateway in SSL mode, it needs to be able to use both the non-SSL port (8088 by default), and the SSL port (8043 by default). You can override the default Ignition ports that appear in the designer.jnlp by adding an address and port on the Configuration -> Redundancy and Network Config page under the Http Addresses section. This may be where port 80 is being specified on your system. I would take a look at that first and see how it is set up. Also check data/gateway.xml to verify what the Gateway is using for default ports.

Thanks for your help. I’m not sure what changed, but our system firewall was configured to communicate on port 8088, but not 80. I changed the port from 80 to 8088 in the gateway.xml file, and that resolved the problem. I’m not sure what changed on this system to change the port from 8088 to 80. I did move the server from one firewall to another, so perhaps the other firewall had port 80 open the whole time.


I think I am having the same problem on a customers site.

Can you advise is it still a requirement to have the http port (8088) open through firewall as well as the https port when using SSL to launch an application from the web page ? or can just the https port be used.

using ignition version 7.7.4 but could upgrade if there is a fix in later version.

Both ports should be open.