Error No binding on property on refreshBinding of a table component

Ignition 8.0.4

I get the following error:

java.lang.IllegalArgumentException: java.lang.IllegalArgumentException: No binding on property “props.columns”.

when i try to invoke this code form a message handler script of a perspective table:

I tried also with “” but the error still remain saying that there there is no binding property.

On the forum this seems a fairly standard method. Am I missing something here?

Could you share the view.json file of the View in question, or at least a screenshot of the props.columns property and property INSIDE the Property Browser?

The error message is pretty clear, and your word choice leads me to believe that the error is accurate, in that the properties in question have no binding in place. In order to use refreshBinding, you must target a property that already has a configured binding. So, does Table.props.columns have a configured binding? What about The fact that you tried to switch your invocation between these two unrelated properties leads me to believe that you’re using refreshBinding without fully understanding how it works.

Please provide a screenshot like this, where I can see the structure of the Table’s properties within the Property Browser:

here you go, I’ve added a couple of screens:

Detail of a column item:

Let me know if you need something more.

I think i got it…dumb me… refreshBinding …refresh a binding which my table doesn’t have:

Sorry for the bothersome question.

1 Like