Error opening Designer only

I can open a project in runtime, but when trying to start Designer I get “Could not create the Java virtual machine”. I have cleared Java temporary files, and rebooted, no luck. I have Java 6 update 22. Thanks in advance for any ideas you have on repair.

Java can have multiple versions installed, and it is possible that Ignition is pointed to the wrong one. You can check what versions of Java you have by going into the Java Control Panel, select the ‘Java’ tab, and then click the ‘View…’ button. This will show all the installed versions and which ones are enabled. You should have an entry with a Product value of ‘1.6.0_22’ (for java 6 update 22). If there are multiple entries here, you might need to change where Ignition is pointing.

This info is in the ignition.conf file in your Ignition install directory. It should have a line at the beginning of the file means that Ignition is pointing to the whatever version of Java is in the path. You can either change the java path to include the right version of java, or you can change this line in the ignition.conf file to point at the java.exe version you want. The new line would look something\Program Files\Java\jre6\bin\java.exeThen just restart the Ignition gateway and you should be good.

I hope this helps,

The information posted above about where Java is found (ignition.conf) is valid for the Gateway, but not for the Designer.

How much memory (RAM) have you allotted to the Designer? I’ve seen people get that message when they allot too much memory, and then it gives that error message on 32-bit JVMs.

Thanks guys. It looks like Robert’s suggestion did it. There were two versions of Java, so I disabled the older one and now designer seems to be functional again.

I upgraded to chrome browser at work (got sick of ie) and found that my designer link stopped working.

I had the designer memory maximum set at 2gb and that worked for the 64bitIE but didnt work for chrome which I now presume is a 32bit browser only and uses the 32bit java.

Thanks Carl - that worked a treat.

Just FYI I reduced the ram max for the designer to 1gb.