Error Opening Designer Project: FileNotFoundException


When I go to open a Designer project, I get this error:

Error launching application:

Like some other posts have suggested, I’ve tried deleting the entire .ignition folder under my username and reloading the project. It just reloads the files and comes up with the same error. Any thoughts?


Here is a snippet from the error log:

Launch failed on step "DownloadRuntimeStep" with error: C:\Users\username\.ignition\cache\resources\runtimes\\bin\rmiregistry.exe (The process cannot access the file because it is being used by another process)
	at java.base/ Method)
	at java.base/
	at java.base/<init>(
	at java.base/<init>(
	at com.inductiveautomation.ignition.client.launch.steps.DownloadRuntimeStep.unzip(
	at com.inductiveautomation.ignition.client.launch.steps.DownloadRuntimeStep.downloadRuntime(
	at com.inductiveautomation.ignition.client.launch.steps.DownloadRuntimeStep$
	at com.inductiveautomation.ignition.client.launch.steps.DownloadRuntimeStep$
	at com.inductiveautomation.ignition.client.launch.steps.AbstractLaunchStep.runLockedAction(
	at com.inductiveautomation.ignition.client.launch.steps.BaseStep.runLockedAction(
	at java.base/

Hello Ryan, If you only deleted the C:\Users\username.ignition\cahce directory then relaunch the Designer. Would that work?

Do you know if that file is actually open/used by another process? Are you able to restart the PC in question and retry the above?

Hi plo,

I just tried deleting only the cache directory and have restarted the machine. Still the same error. So far, I haven’t found that this file is open elsewhere. I tried digging into the Task Manager to see if anything related was running, but did not see anything.

Hello Ryan, At this point, I would suggest reaching out to Support for additional troubleshooting and review. You can reference this forum post in your Support Ticket. Support Home Page | Inductive Automation

Just opened the ticket. Thanks for the help.