Error saving node configuration

Hello Eveyone

I have already detected this problem on two Gateways and have not found the root cause. I have solved it by restarting the tag provider and the log disappears for a few days but then reappears again. Apparently it had caused me no problems but the Gateway has rebooted and it is the only log that is concurrent. Does anyone know how to fix it and what causes it?

batchoperations 26Nov2020 09:15:57 Error saving node configuration
simpleorm.utils.SException$Error: Cannot access destroyed record [InternalJsonStorageInfoRecord [Destroyed SRecordInstance] Dirty-2]

at simpleorm.dataset.SRecordInstance.checkFieldIsAccessible(
at simpleorm.dataset.SRecordInstance.setObject(
at simpleorm.dataset.SRecordInstance.setObject(
at simpleorm.dataset.SRecordInstance.setString(
at com.inductiveautomation.ignition.gateway.redundancy.types.AbstractSynchronizedStateProvider.incrementVersion(
at com.inductiveautomation.ignition.gateway.tags.config.BatchConfigOperation.execute(
at com.inductiveautomation.ignition.gateway.tags.evaluation.BatchContextImpl$
at java.base/java.util.concurrent.Executors$ Source)
at java.base/ Source)
at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$ Source)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$ Source)
at java.base/ Source)|

bump this thread.

I’m seeing a similar error on an ignition gateway. error seems to be occurring every second and filling up my log files. Any help here would be appreciated.

Currently running Ignition 8.0.16

We just encountered this on a server running 8.1.1, recurring 5x/s. Going through restarting tag providers it went down to 4x/s after restarting one remote tag provider with a faulted GAN connection. And restarting the primary local tag provider cleared up the other 4x/s.

I have it too on 8.0.16. Unfortunately have no insights into the cause.

I’m seeing this behavior in 8.0.16. Upgraded from 7.9.5 to 8.0.16 in October 2020. Unsure when this started as I have not been watching the logs. Today needed to do some troubleshooting and found that all of the logs were filled with this message from the past several hours. I just restarted the default tag provider as mentioned above and the messages stopped. I will report back if I see them start again.

Same behavior restarted sometime between yesterday morning and now. It might have gone a full day…

I have the same issue running Ignition 8.0.13 in standalone mode. No redundant gateway.

I posted above having this problem on 8.0.13.
I have since upgraded to 8.1.5 and I am still seeing this problem.

Hello all, I am seeing the same thing. I had recently upgraded from 7.9.10 to 8.1.5 on my Dev system and there have been no issues. Now I did the upgrade from 7.9.10 to 8.1.5 on my Prod system and I am seeing the batchoperations error. Mine is specifically tags.execution.batchoperations with an error stating “Uncaught exception executing batch context.”. These are coming in consistently every 30 seconds.

There is no indication in the error details as to what it is doing or why the error is thrown. I turned on the Debug and Trace Loggers which gave a lot more log entries but none of those pointed to anything either. Based on some of the examples, I have also restarted my gateway but the errors come back immediately.

I wanted to post to the thread to get updates and also share I am having a similar issue and all basic tests are not returning anything for me.

I am seeing the same log error with redundant gateways running 8.1.1. This is causing the backup to not synchronize and now the master is reporting the peer is not connected. I tried to force sync on the backup, but that didn’t work. The updates are stacking up. My next try would be to update and restart the gateways, but I want tech support to look at this first.

Same problem by me here: Ignition 8.1.10 (b2021090812)

Same issue here: Ignition 8.1.10, any idea where this could be coming from?

edit: seems to be a similar error from this post:

The resolution there was a gateway restart. Or upgrading to 8.1.11 or higher.

The Ignition Team is aware of the issue and the next release (version 8.1.15) contains a fix meant to address this log spam. At the moment restarting the Provider/Gateway is the only way to temporarily stop the error spam.

If anyone here is able to reproduce this issue on demand - please send me a DM.

i am getting this with 8.1.8

We are running 8.1.15 and still experience this issue.

Experiencing the same using version 8.1.17

We too are experiencing this issue on 8.1.17. I wonder if it is associated with Transaction Groups?

1 Like

We also see this on 8.1.17.

This gateway has no transaction groups or views or queries, it only has connections to devices and about 15 tag providers only. It does have a bunch of outbound remote connections to load-balanced gateways that have remote tag providers referencing these 15 providers.