Error when uploading project

Hello,

when we are uploading a project (~2MB) to one of our Ignition gateways, the import fails with the following message. Strangely, the project can be imported to other gateways just fine. The gateways are all on the same version 8.1.3 and configured the same way. Any suggestions how to solve this issue?

I already checked the web.xml configuration and the max file size is about 20MB

Thanks. Carsten

org.eclipse.jetty.io.EofException: Early EOF
at org.eclipse.jetty.server.HttpInput$3.getError(HttpInput.java:1134)
at org.eclipse.jetty.server.HttpInput$3.noContent(HttpInput.java:1122)
at org.eclipse.jetty.server.HttpInput.read(HttpInput.java:321)
at java.base/java.io.BufferedInputStream.fill(Unknown Source)
at java.base/java.io.BufferedInputStream.read(Unknown Source)
at org.eclipse.jetty.util.ReadLineInputStream.read(ReadLineInputStream.java:134)
at org.eclipse.jetty.util.MultiPartInputStreamParser.parse(MultiPartInputStreamParser.java:754)
at org.eclipse.jetty.util.MultiPartInputStreamParser.getParts(MultiPartInputStreamParser.java:482)
at org.eclipse.jetty.server.MultiParts$MultiPartsUtilParser.getParts(MultiParts.java:112)
at org.eclipse.jetty.server.Request.getParts(Request.java:2326)
at org.eclipse.jetty.server.Request.getParts(Request.java:2310)
at org.eclipse.jetty.server.Request.getPart(Request.java:2300)
at com.inductiveautomation.ignition.gateway.web.pages.config.routes.ProjectRoutes.importProject(ProjectRoutes.java:368)
at com.inductiveautomation.ignition.gateway.web.pages.config.routes.ProjectRoutes.lambda$mount$4(ProjectRoutes.java:187)
at com.inductiveautomation.ignition.gateway.dataroutes.Route.service(Route.java:252)
at com.inductiveautomation.ignition.gateway.dataroutes.RouteGroupImpl.service(RouteGroupImpl.java:61)
at com.inductiveautomation.ignition.gateway.dataroutes.RouteGroupCollectionServlet.serviceInternal(RouteGroupCollectionServlet.java:54)
at com.inductiveautomation.ignition.gateway.dataroutes.AbstractRouteGroupServlet.service(AbstractRouteGroupServlet.java:38)

Are you uploading from the same server running the gateway or from a browser somewhere else?

Any chance you can run Wireshark on the gateway machine and then do the upload (assuming HTTP and not HTTPS)?

We tried multiple ways

  • import it directly on the gateway server where the project should be imported to
  • from different clients
  • used different browsers (Edge, Chrome, Firefox)

Upload is over HTTP…Can’t use Wireshark on our network

Sorry, you’ll probably have to call support and work with them or wait to be informed of a resolution.

Strangely somebody else reported the same issue this morning: [Perspective] Project Import Failing - #6 by Davide3i

My only guess is that the content length header is being interfered with or reported incorrectly but I don’t know how to confirm that without peeking at the traffic.

yes, saw that as well…strange coincident.

We will contact support to see what can be done

1 Like

Just to update you, I’ve managed to successfully import the project via browser, but only if I upload it from the same server running the gateway; it doesn’t work from a browser running on another system, but on the same network.
Support is helping me sorting out our issue.

Thanks…I tried that before but it did not work either. I will check with support to see what is wrong.

@Kevin.Herron I got the approval to use Wireshark…is there anything in particular that I need to capture / look for