Error writing tags using Kepware

today I have this problem that is going to drive me crazy. My environment is this:

  • Kepware 5.19 as OPC collector
  • Ignition 7.8 (recently updated) connected to Kepware via UA

I’ve setup a Siemens TCP/IP channel in Kepware and connected a Simatic S-1500 CPU. From Kepware OPC client I can see and read/write my tags.
I’ve setup the same tags in Ignition following the right variable type, so values are read but once I try to write a WORD tag (Int4 defined in Ignition) I get this error: Error writing to S_uiDiametro.Value: The value supplied for the attribute is not of the same type as the attribute’s value.

This for any WORD or BYTE variable. I’ve tried to set these with different data type but no luck. From Kepware OPC client I’m able to write these values.

I’ve setup a connection from OPC-UA Server in Ignition and…from there I can write WORD or BYTE tags! That’s make no sense! I don’t want to migrate 1000 tags to Ignition OPC-UA Server!
Perhaps is something related to Ignition’s new 7.8 version?

Does something has experienced the same issue?

Thank you


Yes, I think this has been fixed by in a 7.8.1 beta of the UA module. You can download it here and try it out.

It worked! Thank you

Davide Bortolini