Error Writing to KepWare Tags for a CTI2500 PLC


I am getting a writing error when trying to write to tags. The error indicates it is a type mismatch, but they are both set to be strings in Perspective so I am not sure where the issue is. KepWare is converting the string to and from a 16-bit Word for the PLC, and all the KepWare tags were ported into the Tag Browser automatically through the gateway. I have thousands of these tags to recreate and limited ability to modify the PLCs so figuring out a batch solution in either KepWare or Ignition is preferable.

Error Message

Can you get a Wireshark capture while attempting one of these writes? The connection would need to be configured without security during the capture.

We can look into doing a capture, but may take a few days to organize.

I tried to make the same change from a session on the gateway using the loopback address and got the same error. I will attach some images of the KepWare side if that helps any.

What about this configuration makes you think configuring it as a String in Ignition is okay? The Kepware tag type is set to WORD.

I did not change anything on the OPC tags, that is how they were imported in when I connected the KepWare OPC to the Gateway. It set the type to string for all the analog tags, timer words, and even the variables and doubleword variable automatically.

Hmm, something may be wrong with Kepware. If you drag them into Ignition and it gets assigned a String datatype then either Kepware is reporting the datatype as String, or as some other unrecognized type. But it seems when we write a String it gets rejected by Kepware with Bad_TypeMismatch.

Wireshark capture would show what's happening for sure.

So it took us forever to get IT to help set up the Wireshark. But while we were working on that we discovered that IT had changed the system names of the Gateway and KepWare servers on the network and that the new names had broken our connection to KepWare.
Oddly the system was able to pull the data from KepWare so we did not see the connection issue in the clients until they were being used to write back to the PLC. Once we repaired the connection between the Gateway and KepWare and reloaded the tags from the OPC they started working again and had the proper data types.
Thank you for all your help!

1 Like