Error writing to OK.value: Bad received when trying to write to OPC device tags

While working on a development server with a development PLC connected, when I try to write to tags int he PLC I get an error, “Error writing to OK.value: Bad”. There is another PLC connected to this system as well. Both are Allen-Bradley ControlLogix processors. The second PLC I can write to.

We have swapped the PLC for which the errors are generated and still get the error.
Attached is the configuration, status, and other information relevant to this connection and errors.

The device configuration is all default with exception of the name and the IP address.
I have not seen this before and I’ve used quite a few ControlLogix processors with Ignition.
This particular PLC is a v31.01 version processor.

Can anyone shed some light on what may be going on here?

Thanks,
Mike

1 Like

Is External Access for that tag set to Read/Write in the PLC program? Are there any error messages from the driver in the gateway logs?

I am getting this same error in 8.0.16. I am using KepwareEX6 to interface between Ignition and an IDEC PLC in the field. I can write to the tags using the Kepware quick client in the Gateway, but I get the error when I try to write directly to them from the designer. I also have some tag change gateway events that give me the same error when writing to those tags. I have tried restarting the tags and the OPC-UA module. I have also tried creating a new OPC-UA connection and pointing one of the tags to the new connection. I have tried creating a new tag that points to the Kepware tag I am trying to write to. I tried restarting Kepware. I also tried disabling Kepware and the tag provider and then reenabling them. I can’t think of anything else to try. Do you have any ideas that will help me?Ignition Error 2020-12-16 160913

If you turn the logger for com.inductiveautomation.ignition.gateway.opcua.client.connection.OpcUaConnection to TRACE level and then try to the write again some logs should appear in the Ignition gateway when you attempt the write.

What does this mean? You can write with the Kepware QC, or you can write with Ignition’s QC that is in the gateway?

Ok thanks. I will do that and see what it tells me.

What I meant is I can go to the OPC quick client in the Gateway and navigate to any of the tags I am having issues with and write a value to them using the write function in the quick client. It does not throw an error when I do that and it changes the value as it should.

That is a little strange. I wonder if somehow your tags got read only permissions set on them?

It might be easier to call support and let them take a look.

I checked that in the tag editor and they are setup for read/write, but maybe there is something I missed. I will call support and have them look at it. Thank you for your help.

I have the same issue, any update on how this can be fixed?