Error writing "True" to tag

I have a template repeater that I use for unlocking gates on a work cell. I am using this template repeater on 11 different work cells and each cell has 2 to 6 gates. I have one button on one cell that when pressed, it unlocks the door, but I get a popup that says “Error writing “True” to tag…” Even though I get this error, the button does the required action and the gate unlocks. I have checked that the tag is configured correctly. I have also renamed a known working tag to this tag name and still get the same error.

I am using Version 8.0.5

Is it possible the script run when you press the button is writing to more than one tag and it’s successful writing to the one that unlocks the gate, but not to some other tag?

I have only one tag in Ignition with that name and only one in the PLC.

I didn’t mean two tags with the same name (not possible, at least not at the same path), but rather that if your button writes more than one tag, perhaps the one failing to write is not the one that opens the gate (which is obviously succeeding). That said, this is just a guess as you haven’t shared whether the name of the tag in the error message is the tag that unlocks the gate or whether your script(s) write more than one tag or not when the button is pressed. If the name of the tag that is successfully writing is the name in the error message, this would appear to be a bug.

I have uploaded some screen shots. There are 7 gates on this particular cell. FrontLeftGate is the only one that gives me the error when pressed. Since I am using a template and template repeater, all should act the same. I have also provided the tag structure. I am leaning toward this being a bug.

Gate%20Dataset

Gate%20Template

Move to the ‘script editor’ tab, and see if it’s doing something like system.tag.write(<tagname>, "True") - and if it is, try changing that to system.tag.write(<tagname>, True) (with no quotes).

This is currently what is in the script editor.

Gate%20Script%20Editor

As Paul said, change that

value = u’True’

to

value=True

or better yet

value = 1

You also probably want to update the template parameters in question to actual booleans, if they aren’t already - right now, the script helper is treating them as strings throughout.

Changing from value = u’True’ to value = True gives me the same error.
Changing to value = 1 just changes the error to “Error writing 1 to tag A8/Subline/S800/Gates/FrontLeftGate”

Also, this is only happening with one button out of the 7 on this screen and does not happen to any other of the dozens of buttons on the rest of the line.

Can you edit the tag directly in the tag browser?
Something is different with that tag from the others if only that one fails.
Is it set for External Access Read/Write in the PLC?
Is it set for Read/Write in the Ignition tag configuration?