Factory SQL on Win 2003 Server

Not sure if this is an issue with your software or with Microsoft Server 2003. Anyway I had origionally installed your product on my office PC which is running Win 2000 Pro. It works quite wonderful. However when I installed it on our Win 2003 Server PC it will only come up if you type in the IP address.

If you attempt to run the program using \localhost:8080 it will not run. But if you type in \ it will run just fine.

So should not localhost and be one and the same?

This is a question of name resolution. Typically, “localhost” is mapped to your loopback address ( RFC reserves the keyword for that usage, but it doesn’t matter if your computer is configured that way or not. In most cases they both function similarly and can be thought of as one and the same. I would guess that the mapping is usually configured in the HOSTS or LMHOSTS file. There you could define hostname->IP address resolution or modify/override settings.

There are many “levels” where your computer tries to resolve names to IP address. These range from DNS server to your local computers cache or a local network broadcast. Statically defining a mapping in your HOSTS file has a pretty high priority.

The bottom line is that I wouldn’t worry about it. If you really want to connect from your local computer to itself as localhost, add that to your HOSTS file. Similarly, if you want to call it mycomputer.mydomain or www.yahoo.com, that would work too.