FactoryPMI and IE: Unable to launch specified application

There is a problem with IE’s caching mechanism that causes this symptom:
When you click on a Java Web Start link for FactoryPMI, you get the error message:
“Unable to launch the specified application”
with the details:

An error occurred while launching/running the application.
Category: Invalid Argument error
Could not load file/URL specified

This is caused by IE either not creating or deleting the JNLP file from its cache
before the JWS system can load it. It is usually caused by IE having a full cache. To empty the cache, go to Tools -> Internet Options -> Delete Files.
This should fix the problem. For more details, see:
forum.java.sun.com/thread.jspa?t … &tstart=75

I haven’t seen this problem for awhile. Is this something that Sun could have fixed in a recent release of Java?

No, this is an Internet Explorer problem. You are thinking of another problem where Java complains that some of the JAR files aren’t signed correctly after an FPMI upgrade. This problem has been fixed by Sun in Java version 1.5.0_u6

I try and launch PMI Designer and I get a dialog saying “Checking for latest version”, then an error box stating “Unable to launch FactoryPMI Designer”.

Details:Unable to load resource: 127.0.0.1:8080/gateway/designer/designer.jnlp

This is my 1st attempt to use the software. Using Windows XP-pro, Firefox for default browser.

Then everything shuts down.

Is there a stack trace with more information?

Do you have a local firewall running?

Under Wrapped Exception I have the following:
java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at sun.net.NetworkClient.doConnect(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.openServer(Unknown Source)
at sun.net.www.http.HttpClient.(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.http.HttpClient.New(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
at com.sun.javaws.net.BasicNetworkLayer.doRequest(Unknown Source)
at com.sun.javaws.net.BasicNetworkLayer.doHeadRequest(Unknown Source)
at com.sun.javaws.cache.DownloadProtocol.doDownload(Unknown Source)
at com.sun.javaws.cache.DownloadProtocol.isLaunchFileUpdateAvailable(Unknown Source)
at com.sun.javaws.LaunchDownload.getUpdatedLaunchDesc(Unknown Source)
at com.sun.javaws.Launcher.downloadResources(Unknown Source)
at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
at com.sun.javaws.Launcher.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

I don’t know what stack information you are asking about.

No - I have this annoying balloon that keeps coming up on my quick launch reminding me that I have it turned off.

Are you trying to launch the Designer from the machine running the Gateway, or a different machine?

I have this exact same problem!!! I just compared the lerror messag from the previous post, and its identical to the error message I’m getting.

This is a laptop that is running WinXP and IE7. He was connecting to our FPMI project in July and everything worked OK.

NOTE - We have another WinXP machine, same problem. However, it has IE6.

Nothing has been upgraded on FPMI on the server machine. The actual project has been expanded and new objects and screens added since July.

We’ve tried connecting the project direct (vie Java) and vie EI, same error message.

Other machines that connect to the FPMI Server have had no problems, but most (if not all) of those machines are running Win2K.

ANOTHER THOUGHT - We are cro

ANY IDEAS???

John

You’re having the connect problem? How is your Gateway’s networking set up, do you have some custom settings for multi-NICs? Did a firewall get installed between these computers and the gateway?

OK, Sorry about the delay responding, I’m up to my ears in Tomatoes :slight_smile:

I tried this on another computer that is on the same network, same problem. It only needs to go through one Cisco switch to get to the FPMI server. ( Fresh Java install, Win2K)

The FPMI server has only one NIC installed.

There is no firewall that anybody needs to pass through to get to the FPMI server.

I just connected the above computer directly to the FPMI server directly with a null cable, it worked OK !!!

Back to the Tomatoes, I’ll check back later.

John

well, if you’re getting a connect exception, its definately a networking problem. Look at the Gateway’s cluster map on the Gateway Status page, and look at the “External Addr” Make sure you can ping that address (without the port) from the client machines. Feel free to call us, we could probably do more effective troubleshooting on the phone (or even better - over GoToMeeting)

Good luck with those tomatoes!

Not 100% sure if this did it, BUT:

On the client machines -

Went to the “Java Control Panel” under “Control Panel”.

Although I have “Check for Updates Automatically” checked in the “Update” tab, I clicked on the “Update Now” button and forced an update.

A reboot after the update, and I can now connect to the FPMI Server.

This worked on two differnet machines that had the connectivity problem.

JOhn

Huh - weird! May have been the reboot, but do what works, right?