FactorySQL support

I just realized that support for FactorySQL has ended. I have a customer that I created a system for 11 years ago in Thailand and have been supporting them ever since. Today, we had a guy go to make a small change and the FactorySQL started having trouble. Do I have to upgrade to Ignition if I can’t figure out the problems?

Quite possibly. Keep in mind that old versions of Ignition aren’t supported either. Version 7.7 is the oldest version still supported, and that is expiring soon.

You can always ask here. There’s some old-timers that might be able to help. I don’t know what will happen if you call support. There’s quite possibly 0 people in the support department with hands on experience using FSQL.

The SQL Bridge module is basically a direct descendent (though ported to Java) of FSQL, though, so if your question is generally applicable to groups and how they work it might be answerable.

Hey! Who are you calling old ?!?!? :stuck_out_tongue:

But yeah, some of us have relevant memories. A bit foggy, though. /:


I’d be offended if it wasn’t for my huge ego. :crazy_face:

1 Like

s/old-timers/treasured veteran knowledge holders


Good save!

Reminiscing aside, share what you can and we’ll help as we can.

I don’t know what has happened, but I can’t get the Status or Frontend programs to connect to the service. I have tried rebooting the server and I have tried stopping and starting the service. I even tried uninstalling and reinstalling. I just get this when I start the Frontend:

The last thing I did before this was to restore a backup of the project that had been running as of this morning.

I know nothing about FSQL (not a treasured veteran knowledge holder :laughing:), but in that scenario without any additional knowledge the first thing I’d try other than restoring the same backup again would be to try restoring an older backup. You’ve probably already tried this, but I thought I’d throw it out there in case it’s helpful. Good luck!

I wish I could, but you have to be connected to the service first.

I may have gotten it back by uninstalling, rebooting, renaming the Program Files folder, reinstalling and restoring the backup. But, I have lost the license number. Regardless, the groups say they are ok, but I am having someone check the line now.

Is there any way to get an activation fix over the weekend? They start production Sunday night our time.

Not on the forum. You need to contact support. If you haven’t paid for support, you may not get a fix on the weekend.

That would be a problem. Sounds like reinstall was the way to go; glad you got it going.