Failed to install 8.1.22 on top of 8.1.15

Hi All.

I just tried unsuccessfully updating a customer from 8.1.15 to 8.1.22.
The 8.1.22 image was downloaded on 16/11/22 and I have used it to perform other upgrades successfully.

The customer has a virtual environment hosting a Windows server 2019 instance with only ignition installed. I connected as the system administrator through a console.

First run of the installer, detects that ignition is installed and finds the gateway name (green tick),
I get the usual prompt about taking a backup and press continue.
Installer then says cant detect running gateway do yo want to continue.
If I select yes it gives another error about pre-requisites (assuming that is that it cant stop the gateway it claims to not be able to find)
I hit continue again and it extracts everything before bombing out completely and rolling back.
If I run the installer a second time it detects the install but cant see the gateway name.

I have rolled back the virtual to the snapshot I took prior to the upgrade so no harm done, but interested to know if this is a known issue.


You can try taking a backup of your Ignition 8.1.15 instance and import it onto a different fresh machine install of 8.1.22. If the backup can be restored successfully, then you can just uninstall Ignition 8.1.15 on the main machine, install 8.1.22, and then load your backup.