Faulted context

We recently upgrade to 7.1.1 and everything was working fine until today.

We were doing work in the designer when the gateway went away. Failing to restart it we checked the logs to find a faulted context error. I deleted the context cache and tried to restart. The error remained. There was a warning about being unable to delete a file in a temp dir. I deleted the contents of the temp dir and restarted. Still no luck.

I have uploaded the Gateway log as FaultedContext_7.1.1_Gateway.log.html

I copied off the installation dir and then reinstalled and now things are working again. Let me know if you want anything else.

From a cursory examination of that log, it appears that perhaps the modules weren’t being loaded in the correct order. This is something that has been improved in 7.1.2, but that we haven’t actually seen as a problem in 7.1.1.

Was there anything unusual about the modules that you had installed? Any that you uninstalled manually or experimental ones that you added?


Not on this server. All modules are still installed. Running in demo mode