[FB12678-Investigating] Issues with upgrade

That was not successful either. I set up 7.9 and restored my gateway, then upgraded to 8. I created new projects, did not even try to open an existing project. One of the new projects was based on the global and one not. Both had the same issue- I create a view, save it, and it hangs and fails when trying to re-open. From that point when I try to open a different project, that fails too- the same views appear in the newly opened project. I have to restart Designer to truly open a different project.

Then I deleted all of my proprietary stuff- all projects, all scripts, and exported but the export was still huge, so I am guessing it did not really delete.

Uninstalled, deleted entire Ignition directory, reinstalled, did not attempt to reimport my 7.9 project. Created a new project, which still has the same problem. Will email the GBWK to support@. Thanks, seems like I am doing (and have been doing) something wrong…
UPDATE: I can’t attach GWBK here, too big, and gmail won’t send it- format must have changed, it didn’t formerly have a problem with GWBKs.
How do I get it to you?

I’ve sent you a link where you can upload the backup via PM.

I uploaded to the dropbox link.

I’m attempting to replicate your issue right now. What Operating System are you using? Also, what version of Ignition are you upgrading from?

@NorthPoint: It appears you might have sent us the Backup from your Beta instance. Could you please send your pre-upgrade backup to the dropbox link Kevin provided via PM?

@NorthPoint: I restored from the Beta Backup you provided and was able to access the project which was in place. I was able to create a new View, save the new View, close the new View, and re-open the new View. I was able to reach all listed Page Configurations in a browser.

I then made a new project (in which no Views from the original project were visible), created/saved a View and switched back to the original project without any issue (all original expected Views were in place, and the View which I made in the second project was no longer visible).

I will try again if you should elect to provide the pre-Beta Gateway Backup, or can provide a more detailed list of steps you took to encounter your issues, but at this time I can find no issue with the provided .gwbk.

The backup I sent is from a clean install on a cloud-hosted Linux server. For this test, I did not attempt to import my 7.9 project at all, I wanted to find out if the problems I am seeing are because of the import/conversion of my projects. So I am seeing the same issues (that you are not seeing) with that same gateway running in the cloud- so it seems to not be related to my projects.

HOWEVER, I was able to open and edit resources on that machine using Windows. So maybe the real issue is with my Designer host, which is my MacBook Pro. I use this machine routinely for 7.9 editing, if that makes a difference. Let me know if you want to remote into the machine.

There could be several culprits here, but we’re crossing them off one-by-one.

  1. :x: Beta Build (would be more wide-spread)
  2. :x: Gateway Backup you provided us (worked for me)
  3. :x: Projects (you are experiencing the issue without them in place)
  4. :x: MacBook Pro (my workstation isa macBook Pro)
  5. :question: : Linux OS under Gateway (Just tested on Ubuntu 18.04.1 LTS)

What version of Linux are you deploying the Gateway on? Did your installation encounter any issues? Could you provide the wrapper.log located in <installation_dir>/Inductive Automation/ignition/logs/ either in this thread or at the dropbox link Kevin provided previously?

The server is running right now, and you can connect. Can I send address via email rather than in forum?

Before I connect to your server, could I please have the info I requested?

Sorry, I skimmed over that. It is Ubuntu 18.10. No errors appeared when running the installation from a GUI, from the console via SSH I think there was a warning about a non-writeable file, but otherwise it finished normally.
Just to be clear, I CAN apparently edit this system from WINDOWS Designers. Just not my MacOS. I am attaching the wrapper logs. wrapper.log (1.8 MB)
wrapper.log (6.9 KB)

Your wrapper log seems to indicate that some processes were not completed (you should see | I [Commissioning ] [17:48:48]: Commissioning State updated from needs_commissioning to commissioned before you can consider your Gateway setup to be complete). My installation for example had 169 line present in the wrapper log before I could actually reach my Gateway in a browser.

You may now message me the connection info for your server if you’d still like me to look at it.

I’ll attempt to replicate this on Ubuntu 18.10, but it will take me some time before I can report back on that.

Cody, I will send the info via support@ email in the next couple of minutes. Let me know if you have any issues getting in. I will try to provide VNC access too.

As a reminder for the beta, our Support department will not be accepting questions/information for the beta at this time. Please message Cody the information, as he requested.

I forwarded Cody your messages from support, but yeah, going forward PM would be best.

Sorry, I did not realize that feature was available. Will do.

After deploying my own Ubuntu 18.10 VM and deploying the Beta I was unable to encounter your issue while using a MacBook Pro to create/edit/delete Views and projects.

After connecting to your deployment of the Beta I was unable to encounter your issue while following the same steps with my MacBook Pro.

Is there any possibility that you are using an out-of-date Designer Launcher? Consider deleting your entire local .ignition directory (assuming you don’t have a local Gateway). Once this is done, navigate in a browser to your deployed Gateway and download a new Designer Launcher. Then try to manipulate your project again and see if you encounter the same issue.

I don’t have a /usr/local/ignition directory and don’t have a gateway installed, though I have had one in the past, if that matters. Let me know if you want me to search elsewhere. I could not find a folder labeled “ignition” on HD (other than folders that were just for storing Ignition project information, that is).

I deleted the Designer Launcher and emptied the trash, went to the GW and downloaded and installed a new Designer Launcher. I tried to open the view you created in QAVerifyOne, and the behavior- including the timeout and “unable to deserialize” message remains.


The .ignition directory is considered a hidden folder on Linux systems so it won’t show in the UI. You will need to open a Terminal window and run:

rm -r ~/.ignition

The main reason we are requesting this is this looks to be an issue specifically with the client. We want to make sure that your Designer cache is clean to see if the issue still exists.