[Feature]Option to launch Linux Designer in windowed mode

When launching an Ignition 8.0 Designer in Linux it always assumes full screen, can this be changed to windowed mode as in 7.9, or better still an option to choose?

What OS? It launches in Windowed mode for me on Ubuntu 19.04

I am using Ubuntu 18.04, all my 7.x designers open in windowed mode, so there must be a difference in the 8.x launcher?

Is there a "default.application" entry populated under "global" in ~/.ignition/clientlauncher-data/designer-launcher.json?

Yes there is, currently set as below

“default.application”: “”,

Then it must be something about your environment - are you running an addons or extensions to your window manager? I’m also on Ubuntu 18.04 and any designers I launch (7.x or 8.x) are windowed. You can get in touch with support to try to narrow things down, but that’s a bit of a long shot.

could you try something for me? in that same designer-launcher.json @PGriffith mentioned, can you look for the window.mode entry for the designer you are attempting to launch? it should be null by default. If it is not, could you set the entry to null (without any quotes, simply null). If that fails, attempt to set it to the value "window". Let me know if either of those options work for you.

Jonathan C

1 Like

I have tried the options in designer-launcher.json file, but they have no effect.

Yes, I did have an addon loaded to hide the Desktop top bar (Date and power buttons etc) and if I remove that addon the designer loads correctly, however the Ignition8.x client launcher works perfectly launching clients in either windowed or fullscreen mode regardless of addons, is there any reason why the Designer launcher cannot do the same?

To try the addon go to Add-ons Shell Extensions and type “Hide Top Bar”

1 Like

At a guess, we’re probably doing something different in the designer bootstrapping process inside the primary window opening code that we’re not doing in the client.

Grasping at straws - do the Vision client(s) you’re launching have the menu bar enabled? If they don’t, and you make a new project with the menu bar enabled, does it exhibit the same behavior? If your current Vision projects have a menu bar, then I’m not sure what the difference is, but it may be something we could tweak (but it would be a pretty low priority bug on our side).

Just to clarify here - do you mean it launches maximized, or truly in full screen mode?

It launches in the same way that clients do when you select the “Launch Fullscreen” option i.e. there is no Maximize, Minimize or Close buttons and there is no bar to click on and drag to another monitor.

As per Paul’s suggestion I have just tested this some more with the “Hide Menu Bar” and “Hide Windows Menu” options enable/disabled in the project properties and the client always launches as per the selected option on the client launcher drop-down, with or with the add-on loaded.

Designer with no bar

Client with bar

Dave, I have the same no menu bar issue on 18.04.2 and as far as I know, I have never installed GNOME Hide Top Bar or any similar extensions.

I’m going to try 19.04 and see if anything changes.

I stopped at Ubuntu 18.10; the menu bar appears on top again so that solved the issue for me.

Will, Let me know how that goes in the longer term, I tried 18.10 a few months back and found the GUI crashed/restated after about two hours dumping all my work, I have two screens attached, but don’t think that is usual these days.