[FEEDBACK/BUG] Vision Client Launcher

I was performing some backwards compatibility testing and noticed a few things on the new Vision Client Launcher that I wanted to share.

  • First, the interface is very clean, easy to follow, so well done on that part.
  • When manually adding a new gateway, the popup window disappears when focus to the Vision window is lost. This doesn’t occur when doing so within the Vision Client Launcher window (requires using the “X” to close it).
  • Also when manually adding a new gateway, can a refresh button be added to retry the connection? To try again requires modifying the gateway path.
  • When attempting to add a new gateway manually and it errors out and says “Host Invalid”, is there any way to add more detail about what is invalid. I’ve tried this locally and don’t have a problem connecting, but when on another computer, I only get “Host Invalid” and don’t know where the problem exists. The visionclientlauncher.log does not show any errors.

Running Windows 7 for the Ignition Vision Client Launcher remotely, Windows 10 locally on 8.0.0-beta0 (b2018111102).

I had a similar issue when I tried to use a host name:8088 (even fully qualified) and had to use the IP:8088 instead.

I tried that, but haven’t been successful. I am trying to access a different private network. I’ve verified from internet port scanners that the server is available. I can access it from a web browser. I’m suspecting something is blocking the connection except when using a browser. I know all internet traffic goes through a proxy, so it must not look like a normal web request, or is not honoring the systems proxy configuration.

Ok, there is something definitely wrong with network traffic being blocked. Going back to the old client launcher, I cannot connect to the gateway either, but as soon as I download the jnlp file, I can connect just fine, even to IA’s own demo projects.

… scratching my head…

I believe this was fixed in a recent nightly builds (our internal ticket 11568 I believe). If you find it’s still an issue, feel free to bounce your original topic back up and we’ll investigate further.

@Herbie Thanks for the report/feedback! I agree the retry would be useful without altering the path. Item 2 and 4 sound like bugs. I will get the attention of the team working on launchers and see if they can take a look.

1 Like

This issue was fixed in the build that was uploaded on 11/10.

If you are still having issues, please feel free to open a new post.