Flex repeater - missing scroll bar when justified flex-end

I have a flex repeater (column) that I want the content to be at the bottom, new items are added at the bottom, I have this working well except when the repeater is set to justify 'flex-end', which the setting I am using to get the items to the bottom. When set to flex-end, if there are too many items to fit in the view, there are no scroll bars, the overflow is just hidden.
Overflow is set to auto, but it doesn't work even if I set it to scroll.
Every other setting for the justify parameter results in scrollbars when there is too much content. Is this intended or a bug?
I'm on version 8.1.22

Hi Chris_Murphy,

This is the intended functionality of the justify feature. This link explains why flex-end is appearing without scroll bars.

Is there a reason why you are using flex-end? When an instance is added, it should appear at the bottom automatically. What is your method for adding new instances to the flex repeater?

The reason for flex end is I want all the items in the flex repeater to be to the bottom, I think the method described in your link (an invisible spacer) will work. Thanks.