Flex Repeater not behaving like the video


I cannot get the Flex Repeater to behave like the instruction video. In the video, pressing the Add Array Element under the instances PROPS, brings up a list that includes value, object, and array. When I do the same, something gets added, but it doesn’t look like a value or object. I tried saving, closing, and opening the designer, but the problem still exists. I tried both left and right clicking.


The video is out of date - the instances array must contain a list of objects. There are two special keys available on those objects - instanceStyle and instancePosition, which allow you to customize the style and flex position props of individual views in the repeater. Since the videos were recorded, we fixed the behavior of the ‘Add array element’ shortcut on the top level (instances) to automatically insert a new object with the ‘correct’ property shape. To add more instances, just use the + symbol on instances.

If you want to add more keys (to specify additional parameters on the views), use the '+` symbol on the object:

Thank you for the correction. How do I pass a value to the PARAMS of the view instance? I don’t have a plus sign next to the instances or the array element like your screenshot.


It’s not a sub-key - it would be another object member; “next to” instanceStyle or instancePosition - you should see:


Ok, but how do you add the new object? I’m assuming you’re pressing the blue plus button shown in your screenshot, but I don’t have that. Also, are you adding an object or value to access the PARAMS?

You should hover over the number of the instance, and click the [+] icon which appears, then you should select value.
The new value will be added as “key”. Change “key” to match the key of the param. In Paul’s example, FlexInstanceParams is the key of the param in the instanced View.

1 Like

Unless you’re on a particularly old version, in which case your UI may be a little different…but also in which case you should really update.

1 Like

I was using 8.0.5 and was not getting the plus button when hovering on or around the instance. I upgraded to 8.0.10 and now I can add the parameter. Thank you for your help. You should pull the the video for this topic as it’s very confusing to new users.