Formatted Text field - committed value

Hi all,

I am new to Ignition and scripting. I am trying to sort out an issue with formatted text fields.

I have a formatted text field that works (I thought the way it was supposed to). When I enter text, the text property and the committedValue update. (commit while typing = false).

I fire a property change event on committedValue.

While trying to learn how to add selecting the text on focus, I created another formatted text field to play with. HOWEVER, I cannot get the new field to commit. I have set everything the same as the other, but when I press enter, the text property changes, but not the committedValue property.

So why would a formatted text field not commit on enter? I am sure it is something simple I am missing.

Any ideas?

Thanks, Steven

So this is very disturbing!! I have had a formatted text field working for some time now. I have a script on the property change event and filter on committedValue. Has worked for quite a while. It was working when I posted the op.

Today, it is not working. It will not commit.

Is there something I could have changed somewhere that would affect this?

Thanks, Steven

I think it might be better served if you called IA and get some one on one time.

Also, don’t forget about Inductive University, https://www.inductiveuniversity.com/courses/whats-new-in-ignition-8/8.0. You really need to get through all of the videos first.

@jlandwerlen,

Thanks for the help. I have been through IU…100% and I refer back to them when necessary. I have also read everyting I can find on formatted text fields.

I am pretty sure that someone here will have some technical advice. So many have helped me thus far as I am getting started.

If not, I will give IA a call.

Thanks, Steven

Export a window with the problem happening and attach it here.
This is kind of hard to begin troubleshooting by asking questions.

@MMaynard,

Test_Window.zip (3.9 KB)

So this is really interesting. I created the attached and did some more testing.

Formatted Field 1 was placed in the window, configured with a regular expression pattern and it worked. I then deleted the regular expression pattern and it continues to work with that field blank.

Formatted field 2, is configured as placed in the window and it does not work. Even if you Allow invalid text, it will not commit nor can you directly change the committed value.

It seems that if the component is not configured with a regular expression pattern it will not work, but after it will.

It looks like what probably happened is the pattern got deleted, and the Allow invalid text was false. When I tried another one, it failed to work because I never set a pattern.

Maybe there is more to it than that but that seems to be consistent now. Looks like just a newbie mistake.

Thanks for the help!!

Steven