FPMI upgrade doesn't seem to complete

Hey all,

I’m trying to upgrade my FPMI project as per the ignition upgrade guide. When I try to use my FPMI gateway backup, it seems like it works, but the ignition page continues to say ‘Processing’ with the spinning progress thing. The output is included below.

Starting [createTempDir] ... C:\WINDOWS\TEMP\legacyfpmi3446529947651237183conv (0 ms) Starting [extractBackup] ... done. (468 ms) Starting [verifyBackup] ... Found backup from version 3.3.2 (b2754) (0 ms) Starting [openDatabase] ... done. (1 seconds) Starting [upgradeDatabase] ... DB found at v.38 (500 ms) Starting [importSystemSettings] ... done. (0 ms) Starting [importImages] ... done. (31 ms) Starting [importAuthProfiles] ... done. (0 ms) Starting [importDatasources] ... done. (0 ms) Starting [importProjects] ... Imported projects: [IADemo, PMCS] (0 ms) Starting [cleanup] ... done. (1 seconds) Finished.

It looks like ignition is happy with the upgrade, but it constantly says ‘Processing’ afterwards. If I look around ignition after the upgrade, there is no sign it completed (no projects, connections, etc).

Thanks in advance

Once that part completes the loading symbol turns into a link to go the next stage. Is that not happening? You can upload your backup to inductiveautomation.com/uploads and we can take a look at it.

I see. No, the continue link stays disabled. I’ve uploaded my fpgb file under the name chache.

Thanks again

What version of Ignition do you have? I have version 7.1.6 and the upgrade worked. If you don’t have that version please upgrade by downloading the latest from the downloads section.

I have 7.1.6 b5739. I’m running it alongside the old FPMI if that makes a difference, although I don’t see how they could affect each other.

Ah… after restarting the system it worked like a charm. I didn’t restart after installing it (I don’t recall it being suggested) but that fixed it. I guess it’s always a good idea to restart after installing something.
Thanks for your help!