FSQL and Windows Server 2008. Any issues?

I’ve been developing an application in FSQL running on Win XP where FSQL reads data from Citect OPC server and stores it in a MySQL Server. The app works perfectly in Win XP but when I restore the application on my customers machine running Windows Server 2008 FSQL can’t read data from Citect.
I only get “Config Error” in the preview of the tags. I don’t think there’s any problem with the Citect OPC Server because I can connect to it from two other OPC clients without any problems.
Could it be any issues with running FSQL under Windows Server 2008?
Anybody who can shed some light on this?

/Henrik Wendt

Sounds more like DCOM configuration differences/problems than something inherent to the OS (also, we have a number of customers using 2008 without a problem).

It’s good that you can connect other clients- the big difference is those clients are likely simple applications running under your logged in user account, and FactorySQL is doing everything through its service, usually running under the “system” account. As a quick test, you can change the account that FSQL runs under and see if that makes a difference. To do that, go to Services under Control Panel->Administrative tools. Right click “FactorySQL”, select “properties”, and go to the “Log on” tab. Change the account to be the user you’re currently logged in under. Saving the setting will require the service to be restarted.

If that works, you can leave it, or we can work on changing the DCOM settings to allow System to connect.


You are right about the other clients. The are running as programs and not as a service.
I have had time to try your suggestions earlier today and when I changed the account on the service to the same account that I use for logging into Windows I still couldn’t connect. But I then tried running FSQL as a program instead of a service (found a tip in this forum on how to enable this) I finally managed to connect to the OPC server. So it is most sertainly DCOM issues like you suspected. Do You have any suggestions on how to proceed hereafter?

/Henrik Wendt

Take a look at This Post. #1 and #2 apply to your situation. Follow those instructions and see if it helps. Basically, you’re going to want to give launch and access rights to the “Everyone” group and “Anonymous”.

For testing purposes, make sure that you give the rights for both Local and Remote access. After you get it working you can back it off until it breaks.

Also, make sure that there isn’t a firewall enabled, and if there is, that TCP port 135 is allowed.

Hope this helps, let me know how it goes.


I have now changed the settings as in the link you posted and everything works great. Since this PC isn’t connected to any local network I have decided to use it as it is now and not try to tighten up the security.

Thank you so much for the help.


Great, thanks for the update!

I have again got the same problem with the same machine. Don’t know exactly when it started to fail, but it could have been when there was an update of the UPS software and the machine was restarted.
I have gone through all the settings as above and everything seems fine. Except that it isn’t working when run as a service. If I run FSQL as an application. Bang. I see all the values, nice and pretty. But as a service, nope. :frowning:
It must be some COM or DCOM settings (other than the above as these are verified and are correct) which have changed suddenly but I can’t find it.
Any idea of what to try next?