Fullscreen have scrollbars

Hi, We have this project, running in fullscreen in a Windows 7 64-bit PanelPC.
The project is set to 1024x768. The PanelPC is set to 1024x768.
The taskbar is set to autohide.

I have tried to set the minimum size both much larger or much smaller then the screen resolution.

Either the scrollbar stays, or gets longer (more to scroll)


What do i need to change, so theese scrollbar will not come back?

1 Like

Hi! Welcome to the forums!

Your project size needs to be smaller then the screen resolution. a window border still exists, even if it’s running fullscreen

Here is a sample from one of my projects running on 1280x720




1 Like

Hi.

I tried to lower the screen size even down to




I still see the horizontal scrollbar.

OK, so what about the actual size of the windows?

The reason I put my Minimum Size even smaller than the ‘launch size’, is so that, when I design my windows, I get a rough locator in the designer. If it fits in the box, it’ll fit in the screen.

You may need to adjust your actual window sizes down.

Check all your window sizes, I went through this when designing for 1920x1080.

Actually screen sizes are configured as:
1916x1076, seems that there is a 2 pixel boarder all around when in “full screen” mode.

Hi.

This is quite wierd. playing with minimum size doesnt seem to help





The blue border is from the vnc window im running to check. even without the vnc on it still looks just like that on the panel it self.

The project its mainly a window and using several templates that is show and hidden via the tabstrip, i have tried to make the templates really small.
No change in the scrollbar.

Same issue. I have tried making the application smaller than the resolution. No luck. :imp: :imp: :imp: :imp:

I’ve had the same problem with scrollbars, until finding this post. It seems a bit crap, but i see to have got it working by lowering the resolution of the Client and applet size from 1920 down to 1910.
I have attached a few screenshots of the settings changed. I don’t fully understand all the differences between these settings, but at least it’s made some improvement.
A bit odd, but i guess when designing projects, we need to take a few pixels off our “Maximum” monitor resolution and work within that.

Y’all might find the following full-screen border fixer helpful:

comp = event.source
appRoot = comp.parent.rootPane.parent
while comp:
	try:
		comp.setBorder(None)
		b = comp.getBorder()
	except:
		b = "Fail"
	print "%s (%s) @ %d,%d %dx%d border=%s" % (comp.name, str(comp.getClass()), comp.x, comp.y, comp.width, comp.height, b)
	if comp is appRoot:
		break
	comp = comp.parent

Place it in any startup window’s internalFrameOpened() event. It only needs to run once, but does no harm if run again.
The annoying extra border comes from the JScrollPane’s viewport. That would be the JScrollPane that adds scrollbars to the entire application when any floating window is dragged down or right.

1 Like

Phil,

I am trying to use your code. Is this parsed correctly:

comp = event.source
appRoot = comp.parent.rootPane.parent
while comp: 
	try: 
		comp.setBorder(None)
		b = comp.getBorder()
	except: 
		b = "Fail"
		print "%s (%s) @ %d,%d %dx%d border=%s" % (comp.name, str(comp.getClass()), comp.x, comp.y, comp.width, comp.height, b) 
		if comp is appRoot:
			break
		comp = comp.parent

@weertske, I updated Phil’s original comment to the new forum’s code formatting. Looks like you almost had it.

2 Likes